SSH Daemon not running

Malcolm Kay malcolm.kay at
Thu Aug 28 05:51:58 PDT 2003

On Thu, 28 Aug 2003 01:03, kaging at wrote:
> After a standard install of 4.7 the ssh daemon isn't running
> even though it shows enabled in rc.conf, could it be
> something else I'm missing. It was my understading that ssh
> got installed by default. I did go into /etc/ssh/sshd_config
> and made sure I uncommented the port 22, etc. but still no
> help. I tried reinstalling just to make sure I didn't
> accidentally mess something up but the same thing keeps
> happening. Can someone please point me in the right
> direction?

Dependent on version and/or sshd_config you may need an empty
directory belonging to root:
and a pseudo user:
  sshd:*:22:22::0:0:Secure Shell Daemon:/var/empty:/sbin/nologin

Some how I was missing this user on one machine and found 
sshd would exit rather promptly until I installed this user.

Of course you might have an entirely different problem ;)

Malcolm Kay 

More information about the freebsd-questions mailing list