emergency: can't boot! please help

Malcolm Kay malcolm.kay at internode.on.net
Sat Aug 23 19:24:42 PDT 2003

On Sat, 23 Aug 2003 20:09, OZ wrote:
> Hi, I've got a massive problem and I need urgent help,
> please.
> Trying to set up a dual boot, and I've rendered my
> primary master (which has windows xp) un-bootable.
> On this page:
> http://www.freebsd.org/doc/en_US.ISO8859-1/books/faq/disks.html#NT-BOOTLOAD

For the "same disk" situation this seems fairly clear;
but for the different disk situuation I find it quite confusing.

Nor do I suggest that I know how it should be done!!!!!!!

> in section 9.10... it says:
> ---------------------------------
> "If FreeBSD is installed on the same disk as the NT
> boot partition simply copy /boot/boot1 to
> C:\BOOTSECT.BSD However, if FreeBSD is installed on a
> different disk /boot/boot1 will not work, /boot/boot0
> is needed.
>   "Warning: DO NOT SIMPLY COPY /boot/boot0 INSTEAD
> "/boot/boot0 needs to be installed using sysinstall by
> selecting the FreeBSD boot manager on the screen which
> asks if you wish to use a boot manager. This is
> because /boot/boot0 has the partition table area
> filled with NULL characters but sysinstall copies the
> partition table before copying /boot/boot0 to the MBR.
> "When the FreeBSD boot manager runs it records the
> last OS booted by setting the active flag on the
> partition table entry for that OS and then writes the
> whole 512-bytes of itself back to the MBR so if you
> just copy /boot/boot0 to C:\BOOTSECT.BSD then it
> writes an empty partition table, with the active flag
> set on one entry, to the MBR."
> ---------------------------------
> Well, I read that to mean that if I installed
> /boot/boot0 with sysinstall, THEN i should copy
> /boot/boot0 to C:\bootsect.bsd.
> I did this by following instructions I found
> elsewhere.  In FreeBSD, I tried this:
> dd if=/dev/ad1 of=c:\bootbaby.sec bs=512 count=1

I see two problems here.

Firstly 9.10 (ahead of where you quoted) says
"copy the first sector of your native root FreeBSD partition"

This is probably /dev/ad1s1 or /dev/ad1c not the first sector
on the disk.

Next c:\bootbaby.sec brobably ends up as a file in the FreeBSD filesystem
c:bootbaby.sec (with the \ disappeared) in whatever directory you were in when 
you ran the command.

It is probably easiest to copy this to a DOS format floppy and then again to
C:\bootbaby.sec when back in XP. How you actually get this image into 
windows is not explained in the information.

> (I figured that by calling it "bootbaby.sec", I'd
> rename it later to bootsect.bsd, which is what the NT
> loader dual boot item was set at from a previous
> failed attempt.)
> I may also have copied /boot/boot0 to c:\bootsect.bsd
> from off the CD.  I don't remember at this point --
> I've been panicking for about 3 hours now.
> Anyway... the point is this:
> My NT loader got screwed up, and now I can't even get
> into that disk (Windows XP is on the Primary Master,
> ad0, and FreeBSD is on the Primary Slave, ad1).

Can you still get into FreeBSD and how?
What happens an boot up? What appears on screen?

It sounds as though you may have destroyed the MBR on the master disk
when you went back to sysinstall.

> I've tried creating a boot disk:
> http://support.microsoft.com/default.aspx?scid=kb;en-us;305595
> and even added some options, as suggested here:
> http://tweakhomepc.virtualave.net/dual/rescuebootdisk.html
> (and I used his exact boot.ini -- don't know what the
> original boot.ini was, but his seems about right)...
> but nothing's working.
> The error I get from that one is:
> "Windows could not start because of a computer disk
> hardware configuration problem.
> Could not read from the selected boot disk.  Check
> boot path and disk hardware.
> Please check the Windows documentation about hardware
> disk configuration and your hardware reference manuals
> for additional information."
> Now, this might not seem like a FreeBSD issue, since
> it's the Windows XP disk I can't get into, but it was
> the FreeBSD boot loader that got me into this mess.
> The FreeBSD warning was:
>   "Warning: DO NOT SIMPLY COPY /boot/boot0 INSTEAD
> and although I was very careful about this and I was
> sure I WASN'T doing what they were warning me
> against...  I think that's what has happened.

I don't believe you managed to make the image available to the loader
so this is unlikely to be the problem.

> How do I fix this?  I've even tried attaching the
> drive to another computer (Win XP) as a Slave, to see
> if I could "SEE" the contents of the drive, but I
> can't.
> Please don't tell me this disk is gone.  There's got
> to be a way to re-create the original partition table
> or re-write a new one that will see the disk's
> contents, etc.???

If you know what you did in installing XP then it might be possible for
someone who knows more about how XP sets up disks to make a 
reasonable guess. That person is not me.

> This has been a very bad day for me.  PLEASE help, I'm
> begging.  Thanks.

Malcolm Kay

More information about the freebsd-questions mailing list