ed1 network problems on laptop

Michael A. Smith msmith at code-fu.com
Thu Aug 21 12:19:09 PDT 2003

I've got a Sony VAIO PCG-FX101 (vanilla Celeron 600 laptop). It's run 
FreeBSD without a problem before. I just installed a new hard drive and 
installed 4.8-RELEASE on it. Now, I'm having all kinds of network 
problems that I didn't have a few days ago with the exact same 
hardware/OS (except the hard drive). I'm using a SMC PC-Card NIC (comes 
up as ed1).

When I try to cvsup my source tree or ports, I get a message like this:

   TreeList failed: Network write failure: Connection closed

That's not the only error I've seen while cvsupping, but the only one 
I've seen today. It happens every time I try to cvsup.

When FTPing anything, the connection hangs mid-session (unless it's a 
small up/download). I've been able to install some ports, but usually 
they hang on the FTP download.

When SSHing to other hosts, I can go merrily along, but within five or 
ten minutes, I lose the connection.

I was able to successfully cvsup my source tree and ports tree AND 
portinstall XFree86-4 and xcfe4 (big downloads, LOTS of dependencies). 
The way it worked was this: I'd tried and tried to cvsup without luck. I 
left the machine on and went to the office. FROM MY OFFICE FREEBSD 
MACHINE, I was able to log into my home machine, su to root, flawlessly 
cvsup and portinstall a bunch of things. I thought my problems were 
somehow solved -- WRONG. When I try doing any of those things from the 
machine itself, I can't.

Since I was able to cvsup remotely, I've rebuilt my whole system (world 
and kernel) to 4.8-STABLE.

I've done web searches on the error string above and found people with 
the same problem (apparently), but no definitive solution. I've made 
sure that there's no IRQ conflict with the NIC (it shared IRQ 3 with the 
sio1, which I've commented out of the kernel and rebuilt). I've also 
made sure the laptop's BIOS is set for a non-PNP OS.

I had 4.8-STABLE running on this machine a few days ago (on a too-small 
hard drive) without a hitch. No network glitches at all. Argh.

Any clues?? I don't wanrt to re-install from scratch -- and doubt it 
would do any good!

Michael A. Smith <msmith at code-fu.com>
Programmer at Large

More information about the freebsd-questions mailing list