Can't build kernel with 4GB of memory (MAXDSIZE)

Mike Hunter mhunter at ack.Berkeley.EDU
Wed Aug 20 11:13:48 PDT 2003


I can't seem to get a new kernel working with increased memory parameters:

I tried adding the following to my KERNCONF:

options         MAXDSIZ="(4096UL*1024*1024)"
options         DFLDSIZ="(2048UL*1024*1024)"

On 5-current (as of about 6 months ago) this produced an ungraceful
init.conf bomb-out.

I tried again yesterday with a 4.8 box 

uname -a
FreeBSD 4.8-RELEASE-p3 FreeBSD
4.8-RELEASE-p3 #1: Tue Aug 19 14:24:09 GMT 2003
root at  i386

(cvsup'd some time after August 11)

It gave me a similar but slightly more graceful bomb-out "I'm not going 
anywhere without my init!\n\nRebooting in 15 seconds....")

So, I think I'm missing something here :)  The machine in question has 4GB
of ram, and I'd like to be able to use all of it for some nasty
number-crunching I'm trying to do.  Any suggestions?

Please cc me as I am not on the list.


Mike Hunter

More information about the freebsd-questions mailing list