make buildworld stoppes with an error

ertank at ertank at
Sat Aug 16 00:43:58 PDT 2003


I was trying to upgrade my 4.7-RELEASE system to FreeBSD 5.x-CURRENT. 

After "make buildworld", the process comes until the stage 4 and there it 
gives me the below error which is a copy-paste from the output: 

>>> stage 4: populating /usr/obj/usr/src/i386/usr/include
cd /usr/src; MAKEOBJDIRPREFIX=/usr/obj  MACHINE_ARCH=i386  MACHINE=i386  
CPUTYPE=  GROFF_BIN_PATH=/usr/obj/usr/src/i386/legacy/usr/bin  
DESTDIR=/usr/obj/usr/src/i386  INSTALL="sh /usr/src/tools/"  
sbin:/usr/bin /usr/obj/usr/src/make.i386/make -f Makefile.inc1 
SHARED=symlinks par-includes
===> share/info
cd /usr/src/share/info; /usr/obj/usr/src/make.i386/make buildincludes; 
/usr/obj/usr/src/make.i386/make installincludes
===> include
cd /usr/src/include; /usr/obj/usr/src/make.i386/make buildincludes; 
/usr/obj/usr/src/make.i386/make installincludes
creating osreldate.h from
make: no target to make.
*** Error code 2 

Stop in /usr/src/include.
*** Error code 1 

Stop in /usr/src/include.
*** Error code 1 

Stop in /usr/src.
*** Error code 1 

Stop in /usr/src.
*** Error code 1 

Stop in /usr/src.

My kernel is GENERIC kernel, and system is:
FreeBSD 4.7-RELEASE FreeBSD 4.7-RELEASE #0: Wed Oct 
9 15:08:34 GMT 2002     
root at  i386 

FreeBSD 5.x-CURRENT sources are cvsupped as of 15 August 2003. 

I tried to do a "make buildworld" with the FreeBSD 4.8-STABLE sources. I get 
an error with that sources, too. But I am not sure if it was the same error. 

Any one else has any idea about the problem? 

Best Regards, 

Ertan Kucukoglu
ertank at

More information about the freebsd-questions mailing list