groff: can't file `DESC´ file

Hartmann, O. ohartman at
Mon Aug 11 04:04:49 PDT 2003


Tried today to make a make world on a FreeBSD 5.1-RELEASE-p2 box. Process
died with the following error:

===> share/doc/usd/13.viref
sed -e 's:^\.so$:&.\\*[.T]:' /usr/src/share/doc/usd/13.viref/../../../../contrib/nvi/docs/USD.doc/vi.ref/vi.ref >
sed -e 's:^\.so index\.so\.\\\*\[\.T\]$::' vi.ref-patched |  groff -Tascii -U
-I/usr/src/share/doc/usd/13.viref/../../../../contrib/nvi/docs/USD.doc/vi.ref -t -mtty-char -me -o1- -U -z
groff: can't find `DESC' file
groff:fatal error: invalid device `ascii'
*** Error code 3

Stop in /usr/src/share/doc/usd/13.viref.
*** Error code 1

Stop in /usr/src/share/doc/usd.
*** Error code 1

Stop in /usr/src/share/doc.
*** Error code 1

Stop in /usr/src/share.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.

This occured after a crash of a make world and something went wrong with groff/tmac.

I tried to recover from that vrash but with no success.

I did:

- tried to install groff manually, no success, don't know how and some GOOGLE- reports about a similar
  problem do not work (like a make clean obj depend install).

- set GROFF_FONT_PATH=/usr/share/groff_font manually, also GROFF_TMAC_PATH, no success!

- I clean /usr/src and polled for completely new stuff and tried to reinstall world, no success!

- selected NO_SHAREDDOC in /etc/make.conf, this works but something went wrong with the manpages, no manpages
  available after this. man xxxx does not work after this procedure.

manpages also do not work.

Can anyone help?

Thank you very much in advance,

O. Hartmann

ohartman at
Systemadministration des Institutes fuer Physik der Atmosphaere (IPA)
Johannes Gutenberg Universitaet Mainz
Becherweg 21
55099 Mainz

Tel: +496131/3924662 (Maschinenraum)
Tel: +496131/3924144 (Buero)
FAX: +496131/3923532

More information about the freebsd-questions mailing list