Error building XFree86-Clients

Patrick O'Reilly bsd at
Sat Aug 9 12:34:03 PDT 2003

On Saturday 09 August 2003 21:20, Stephen Hilton wrote:
> On Sat, 9 Aug 2003 20:48:23 +0200
> "Patrick O'Reilly" <bsd at> wrote:
> > Hi Folks!
> >
> > I have a number of XFree86 Font ports which will not upgrade from 4.2 to
> > 4.3, and in each case the error is as below.
> >
> > I'm afraid the error "/usr/libexec/elf/ld: cannot find -lXfont" does not
> > mean much to me!
> >
> > Can anyone give a pointer here?
> Patrick,
> Install portupgrade from ports and use that to upgrade. It
> really is the *best* IMHO way to get around these kind of
> problems.
> Regards,
> Stephen Hilton
> nospam at

Hi Stephen - thanks for your response too.

I do use portupgrade actually.  This is probably why I am now so lost, because 
usually everything just works so easily.

I've tried these upgrades with and without -r and -R, all to no avail.  The 
only option I have NOT tried is to manually de-install the ports, and then 
re-install them.  But that would seem pointless as this is basically what 
portupgrade does for you.

Hurumph !

Might there be any merit in portupgrade -f on the libraries?

Patrick O'Reilly.

More information about the freebsd-questions mailing list