strange boot-time error

giamma gmario.tamagnone at
Thu Aug 7 17:21:52 PDT 2003

Hello to all the list. I have an ugly problem at boot time, maybe in a rc* 
script. At boot time i can read this lines on the screen:
can not chdir(/var/spool/clientmqueue/) : Permission denied.
Program mode requires special privileges, e.g. root or TrustedUser.
Now I try to login as normal user: login:giamma password:xxxxx
i get the error: can't find root directory (Arrrrgh!)
If I login as superuser i have no problem, and i can see that the user 
directory is present, also the / dir. If I try doing #su giamma
I get the error: su:/bin/csh:permission denied. duh! What's happening?
Also if I try doing something like #sendmail stop I get the same error at the 
mmm. Let me see. Sure it's a sendmail problem, but where's the mistake?
I haven't touched /etc/rc.sendmail, nor /etc/rc.d/sendmail at all.
Also /etc/password, /etc/groups look good. I've only tried to modify 
/boot/loader.conf (hostname, boot verbose, loading modules)
but I've not touched sendmail at all! Someone have any idea? I've tried to 
look at the faq, but I haven't found anything that could fit the problem.
What I did? Any help would be appreciated. Thanks in advance.
Greetings, Gianmario.

More information about the freebsd-questions mailing list