NATD and PPP problem

Francesco Casadei fcasadei at
Tue Aug 5 15:06:16 PDT 2003

On Tue, Aug 05, 2003 at 05:02:50PM +0200, Jacob Vennervald wrote:
> Hi
> I've installed a FreeBSD 4.8 machine, which I wanna use as a 
> NAT/Router/Firewall.
> I have setup the pppoe connection which works perfectly and then I've 
> tried to setup the machine as a NAT Router by setting the following in 
> the rc.conf:
> firewall_enable="YES"
> firewall_type="open"
> natd_enable="YES"
> natd_interface="tun0"
> But when I restart the machine it gives me the following error:
> "Firewall rules loaded, starting divert daemons: natdnatd: tun0: cannot 
> get interface address"
> When I log in and type "ifconfig" I can also see that the tun0 interface 
> doesn't exist, but when I turn off the two natd settings in rc.conf and 
> reboot it does exist.
> Can anybody help?
> Cheers,
> Jacob Vennervald
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"
> end of the original message

Use the -dynamic flag if the tun0 interface is not configured when natd
starts up. From natd(8) manpage:

         If the -n or -interface option is used, natd will monitor the
         routing socket for alterations to the interface passed.  If
         the interface's IP number is changed, natd will dynamically
         alter its concept of the alias address.

Add the following line to /etc/rc.conf:


Even if you solved the problem, you may also want to try this solution.

	Francesco Casadei
You can download my public key from
or retrieve it from a keyserver (,, ...)

Key fingerprint is: 1671 9A23 ACB4 520A E7EE  00B0 7EC3 375F 164E B17B

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list