FreeBSD compatability with an IBM Aptiva 2137-E30..

Steffen Schumacher Steffen at
Sun Aug 3 14:59:02 PDT 2003

I have an IBM Aptiva 2137-E30, from which I would like run FreeBSD. To
start with I wanted the 4.8 version, but now I think I'll pretty much
take anything that works. The PC comes with a bootable CDROM drive,
which will boot your Microsoft Windows installation CDs (have tried with
w2k and XP). Also it has a 3½" floppy, which also will boot which ever
FreeBSD) bootable floppy I feed to it.
This is what I've tried so far, all of it has failed.
1.         Bootable CD from the 4.8 MINI-ISO image.
           When attempting to read the kernel, it halts with this
           Invalid format
           >>FreeBSD/i386 BOOT
           Default: 0:fd(0:a)/kernel
           And pretty much regardless of what I try, the last two lines
is repeated.
           I haven't tried with another ISO (5.1 would probably be the
next candidate), but I'm not going to either, because the, otherwise so
fail proof, floppy installation disks also fails for both 4.8 and 5.1.
2.         Floppy installation disks v. 4.8
           The kernel disk boots up, seemingly fine, and prompts for the
mfsroot disk.
           The mfsroot disk also reads fine, and ends up prompting me,
if I want to boot kernel.
           I figure this must be what I'm supposed to do, so I hit the
ENTER button, but after 2-5 seconds, an error occurs.
           There are two different which I have seen in this situation.
To the best of my knowledge there is no logical pattern in which of the
two I get at a specific time I try to boot.
           The first is like this. The following text is printed with
white (not grey) text in the bottom of the screen:
           Fatal double fault: 
           Eip 0xC030EE78 
           Esp 0xC05E3EB8 
           Ebp 0xC05E3EC0
           Panic: double fault
           Uptime 0s  
           At this time, all I can do is to reboot.
           The second error is like this. Almost every of the CPU's
registers is dumped to the screen, in a continuous loop, scrolling down
the screen.
           The values of the registers do NOT change. I'm sorry, but I'm
too lazy to copy them onto this mail, but I suspect that the EIP, ESP,
EBP registers all have the same value as in errortype 1.
3.         Floppy installation disks v. 5.1
           These disks behave EXACTLY like the 4.8 ones, except the
second error the registers are only printed out once, and as a result
there is also no scrolling down the screen.
I have tried to find updates for the BIOS, as it dates all the way back
to august 1997, but there isn't any available from IBM. I've tried
putting the CDROM as master drive and the hd as slave, and the other way
around. I've scanned my floppies rigorously with no signs of flaws what
so ever.
I know that there is some hardware on which FreeBSD will not run, and
I'm starting to fear that this in one such piece of hardware.
Anyone have any ideas?
I really would like to avoid having to install linux in stead.
//Steffen [at] Schumacher [dot] dk

More information about the freebsd-questions mailing list