Odd behavior on 4.8-REL since installing KDE 3.1

J. Seth Henry jshamlet at comcast.net
Sun Apr 27 17:27:29 PDT 2003

I recently updated my X app server to 4.8-REL, largely to gain easier
access to KDE 3.1, which is vastly improved (so far) over previous
released of KDE. However, since installing it, I have noticed strange
behavior systemwide. I'm not sure if this is really a FreeBSD question,
but I'm hoping someone else has seen this, or can diagnose where it is
coming from.

The first odd thing is that scripts run by cron now return an error (by
email) saying:

Date: Sun, 27 Apr 2003 20:05:00 -0400 (EDT)
From: Cron Daemon <root at alexandria.gambrl01.md.comcast.net>
To: root at alexandria.gambrl01.md.comcast.net
Subject: Cron <root at alexandria> * /usr/local/bin/sndate

Desktop: not found

This started a few hours ago, shortly after I logged off as root. This
appears to be causing the scripts to fail, so I would call this a bit

The other is just mildly annoying. I have four dedicated X terminals, and
a Windows PC. They all use DHCP to get network info. Having blown all my
naming originality on the dedicated hosts, I just call them dhcp0 -> dhcp9
(I added a few extras for guests)

Now, when I run uptime, I get this:

alexandria# uptime
uptime: /dev/dhcp0:0: No such file or directory
uptime: /dev/dhcp4:0: No such file or directory
 8:13PM  up 20:41, 0 users, load averages: 0.08, 0.04, 0.01

I first noticed this after I ran it while logged into (you guessed it)
dhcp0. Later, I logged into my bedroom terminal, and noted that it added
/dev/dhcp4. It appears to be permanent. I have even rebooted the app
server, and it still appears. What is odd is that it even appears on
console, and via ssh. It also appears for all users, root included.

Again, this appears to be kde related. This, too, started after I
installed the load. Unfortunately, I upgraded both the OS and the desktop
manager at the same time - but it looks suspicious.

Other notes:

The upgrade was a clean new install. I backed up important configuration
files, and restored where necessary. Only files such as fstab, /etc/ssh/*,
smb.conf, etc were restored. (although any user-specific KDE specific
stuff from 3.0 would have been retained with the user accounts)

I use kdm as the login manager, with only a few modifications to the base
scripts (primarily to allow network access, and disallow console access),
but is running clean otherwise.

As an attempted diagnostic tool, I modified one of the shell scripts run
by cron to echo $PATH, but I get no result. (which appears to confirm that
the scripts aren't being run.

alexandria# cat /usr/local/bin/sndate
echo $PATH
/usr/local/bin/statnet `date "+DATE=%m%d%y"` > /dev/null
sleep 1
/usr/local/bin/statnet `date "+TIME=%H%M"` > /dev/null
sleep 1
/usr/local/bin/statnet `echo "SN1 PMES1=Outdoor T:
"``/usr/local/bin/statnet r1s2 | cut -c 10-` > /dev/null

This script updates the clock in my thermostat, and displays the
otherwise hidden outdoor temperature to the LCD. (it has five sensors,
only two of which are displayed on the primary LCD.

I can't think of what else might be helpful. I use tcsh for all accounts,
including root. I have modified the scripts to clear the screen after
login, and print the uptime. They also clear the screen before logout, but
are otherwise unmodified. I can't see how this affects anything, as the
scripts call sh to run, but you never know.

Any help would be appreciated, though I am probably going to follow up on
the KDE questions list as well. It's a shame, because KDE 3.1 is,
otherwise, a vast improvement over previous releases. I've been using it
fairly heavily, and no bombs yet!

Seth Henry

More information about the freebsd-questions mailing list