NFS problems (RPC)

Jer jeremy at
Sun Apr 27 16:22:38 PDT 2003

Dear all

I tried to get nfs working betwen 2 hosts.

started nfsd mountd and portmap rpc.statd on the server

and ran mount on the client
I got the msg pooh2:/dailyiso: nfsd: RPCPROG_NFS: RPC: Program not registered

after issuing rpcinfo -p on the server it returns
   program vers proto   port
     100000    2   tcp    111  portmapper
     100000    2   udp    111  portmapper
     100005    3   udp   1022  mountd
     100005    3   tcp   1022  mountd
     100005    1   udp   1022  mountd
     100005    1   tcp   1022  mountd
     100003    2   udp   2049  nfs
     100003    3   udp   2049  nfs
     100024    1   udp   1013  status
     100024    1   tcp   1019  status

but if I issue that on the client as rpcinfo -p pooh2
No remote programs registered.

we tried on another system to start portmap nfsd and mountd
then isued a rpcinfo -p test.system
and that worked fine
the problems appears to be with something on the server yet I do not know wat

any ideas


More information about the freebsd-questions mailing list