Another qmail question - envelopes staying in "limbo"

Liquid liquid at
Wed Apr 23 22:21:55 PDT 2003

> -----Original Message-----
> From: Sandro Mancuso [mailto:sandro.mancuso at]
> Sent: April 23, 2003 1:24 PM
> Hey all...
> I'm using qmail for mail and qmail-pop3d for pop.  Things appear to be
> running smoothly, except for one thing I've noticed.  Occasionally,
> emails appear to stay stuck in queue.  For starters, I followed the
> steps from "Life with qmail" to install qmail - I also installed
> daemontools.  When emails appear to not be coming in, I simply do
> "qmailctl stat" and it shows the following:
> freebsd# qmailctl stat
> /service/qmail-send: up (pid 134) 60817 seconds
> /service/qmail-send/log: up (pid 79360) 0 seconds
> /service/qmail-smtpd: up (pid 79308) 16 seconds
> /service/qmail-smtpd/log: up (pid 79361) 0 seconds
> /service/qmail-pop3d: up (pid 79313) 16 seconds
> /service/qmail-pop3d/log: up (pid 79362) 0 seconds
> messages in queue: 22
> messages in queue but not yet preprocessed: 21
> Usually, when emails appear to be in "limbo" (I don't know what else
> to
> call it?) that last line says 0, regardless of what the one before it
> says.  After a while, I'll do qmailctl doqueue and the messages will
> be
> processed.
> I tried that this time and it didn't work.  Can anyone explain what
> exactly is going on when this happens? It goes through this about 2-3
> times a day, but like I said, this time was different.
> Thanks,
> Sandro

Ok, somewhat of an update on this.  I rebooted the server, just for fun
I guess, and sure enough, when I did, all those emails that were "in
queue" wound up being sent, and it worked.  Now I've just returned home,
and the same thing seems to have happened again.  Either something
happens every ?? hours, or every ?? mails I think.  Hope this sheds some
light on this for you all

Thanks again,

More information about the freebsd-questions mailing list