cdrom - device not configured error

Michelle Weeks tristan11 at
Sun Apr 20 15:08:48 PDT 2003

On Sunday, April 20, 2003, at 12:17 PM, Christopher Rosado wrote:

> Hash: SHA1
> On Friday 18 April 2003 03:35 pm, Michelle Weeks wrote:
>> i'm trying to mount /dev/acd0c and i keep getting the error "device 
>> not
>> configured".  the freebsd handbook states that either the drive does
>> not think there is a cd in the tray or the machine can't see the drive
>> on the bus.  i've put the cd in the tray several times, tried multiple
>> cds that can be read by another freebsd machine and still the error
>> "device not configured".  this is a production server and i would like
>> to avoid bringing the server down if at all possible.  is there a way
>> to tell if the machine can see the cdrom drive on the bus?  or is 
>> there
>> something else that could be causing this behavior?
> I noticed this several months ago after CVSUP'ing to a new codebase 
> (don't
> remember if it was to a new -RELEASE or -STABLE, although I think it 
> was
> around 4.6[.x]).  A friend on IRC also ran into this sometime after I 
> did, so
> I'm fairly sure it wasn't something specific to my machine... perhaps 
> a bug.
> Using "mount_cd9660 /dev/acd0a /cdrom" worked for me and my buddy.  
> FWIW, the
> *correct* behavior is working for me again on 4.8, so you may want to
> consider a CVSUP.

that did it!!!!  :  )   thank you so much and thanks to the rest of the 
folks who also tried to help me out.

> - --
> Christopher Rosado
> "Liberalism leads to loss of liberty." - Me
> Version: GnuPG v1.2.1 (FreeBSD)
> iD8DBQE+ovIsk41LrboeC7gRAh30AKCO1MnLEFtAnXU56/OrV5QeWHXZ2wCdHA9T
> aLZT2QGSNQ9h8eht5IdvrRM=
> =ySP9

More information about the freebsd-questions mailing list