DE-650 hangs on insertion?

Simon Phillips srp at
Sat Apr 19 00:35:35 PDT 2003


Having issues with this card under FreeBSD 4.8-RC1.  The laptop I'm
trying to use it on is a Dell Latitude C600.

All appears OK when I insert the card, but after a few seconds, the
system appears to hang (well, perhaps just keyboard and mouse input,
but I can't move the mouse or type anything).  I can remove the card
and the system will start working again, and all my mouse movements
and keystrokes will be unbuffered and executed. 

I get the following log entries upon inserting the card:

Apr 19 16:56:45 sindri /kernel: pccard: card inserted, slot 0
Apr 19 16:56:51 sindri pccardd[108]: Card "D-Link"("DE-650") [Ver 01.00] [(null)
] matched "D-Link" ("/DE-6[56]0/") [(null)] [(null)]
Apr 19 16:56:51 sindri pccardd[108]: Using I/O addr 0x240, size 32
Apr 19 16:56:51 sindri pccardd[108]: Setting config reg at offs 0x400 to 0x60, R
eset time = 50 ms
Apr 19 16:56:56 sindri pccardd[108]: Assigning I/O window 0, start 0x240, size 0
x20 flags 0x5
Apr 19 16:56:56 sindri pccardd[108]: Assign ed0, io 0x240-0x25f, mem 0x0, 0 byte
s, irq 11, flags 0
--- (At this point, the system hangs)

Upon removing the card, I get:

Apr 19 16:57:04 sindri pccardd[108]: driver allocation failed for D-Link(/DE-6[5
6]0/): Device not configured
Apr 19 16:57:05 sindri /kernel: pccard: card removed, slot 0
Apr 19 16:57:05 sindri pccardd[108]: ed0: D-Link (/DE-6[56]0/) removed.

I have the same issue with this card whether I plug it in by itself, 
or with another card.

Other PCMCIA cards successfully tested in the machine under the
same release of FreeBSD, with the same kernel and pccard config are:

- Orinoco Gold card (uses wi driver, all OK)
- Xircom REM100 card (comes up as CEM56, uses device xe0, both modem
  and ethernet are good)
- SMC EtherEZ PC Card (uses sn driver, all OK)
- Some form of D-Link Intel Pro/100 clone (can't remember, but I did
  use this card at some point successfully).

And I have used the DE-650 successfully in the past on the same laptop,
and a Toshiba Satellite Pro 430CDT (yes, old, I know) under Linux.

I've checked pccard.conf for a couple of things.  According to a list
posting I read elsewhere sometimes PCMCIA cards don't work due to memory
conflicts.  I tried changing the memory from '0xd4000 96k' to '0xd0000 16k'
I also changed the list of IRQ's to those actually available in the machine.  
Neither of these changes (either alone, or in combination) make any 

I also tried changing my kernel to use 'device ed' instead of the default
'device ed0 blah blah..' - this also had no effect. 

The dmesg output follows:

Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 4.8-RC1 #0: Sat Apr 19 16:35:50 EST 2003
    srp at sindri:/usr/src/sys/compile/GENERIC
Timecounter "i8254"  frequency 1193182 Hz
CPU: Intel Pentium III (751.71-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x68a  Stepping = 10
real memory  = 134066176 (130924K bytes)
config> di sio1
config> di sn0
config> di lnc0
config> di ie0
config> di fe0
config> di cs0
config> di fdc0
config> di bt0
config> di aic0
config> di aha0
config> di adv0
config> en ata1
config> po ata1 0x170
config> ir ata1 15
config> f ata1 0
config> q
avail memory = 125095936 (122164K bytes)
Preloaded elf kernel "kernel" at 0xc053d000.
Preloaded userconfig_script "/boot/kernel.conf" at 0xc053d09c.
Preloaded elf module "snd_maestro3.ko" at 0xc053d0ec.
Preloaded elf module "snd_pcm.ko" at 0xc053d190.
Pentium Pro MTRR support enabled
md0: Malloc disk
Using $PIR table, 9 entries at 0xc00fbd70
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Intel 82443BX (440 BX) host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
agp0: <Intel 82443BX (440 BX) host to PCI bridge> mem 0xf4000000-0xf7ffffff at d
evice 0.0 on pci0
pcib1: <Intel 82443BX (440 BX) PCI-PCI (AGP) bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <ATI model 4c46 graphics accelerator> at 0.0 irq 11
pcic0: <TI PCI-1420 PCI-CardBus Bridge> irq 11 at device 3.0 on pci0
pcic0: PCI Memory allocated: 0x88000000
pcic0: TI12XX PCI Config Reg: [ring enable][speaker enable][CSC serial isa irq]
pccard0: <PC Card 16-bit bus (classic)> on pcic0
pcic1: <TI PCI-1420 PCI-CardBus Bridge> irq 11 at device 3.1 on pci0
pcic1: PCI Memory allocated: 0x88001000
pcic1: TI12XX PCI Config Reg: [ring enable][speaker enable][CSC serial isa irq]
pccard1: <PC Card 16-bit bus (classic)> on pcic1
isab0: <Intel 82371AB PCI to ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX4 ATA33 controller> port 0x860-0x86f at device 7.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
uhci0: <Intel 82371AB/EB (PIIX4) USB controller> port 0xdce0-0xdcff irq 11 at de
vice 7.2 on pci0
usb0: <Intel 82371AB/EB (PIIX4) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
chip0: <Intel 82371AB Power management controller> port 0x840-0x84f at device 7.
3 on pci0
pcm0: <ESS Technology Maestro3> port 0xd800-0xd8ff mem 0xf3ffe000-0xf3ffffff irq
 5 at device 8.0 on pci0
pcm0: <SigmaTel STAC9721/9723 ac97 codec>
orm0: <Option ROM> at iomem 0xc0000-0xcffff on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model Generic PS/2 mouse, device ID 0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
ad0: 9590MB <FUJITSU MHR2010AT> [19485/16/63] at ata0-master UDMA33
acd0: CDROM <TEAC CD-ROM CD-224E> at ata1-master PIO4
Mounting root from ufs:/dev/ad0s1a
IP packet filtering initialized, divert disabled, rule-based forwarding enabled,
 default to deny, logging disabled
pccard: card inserted, slot 0
xe0 at port 0x2e8-0x2ef iomem 0xd0000-0xd0fff irq 11 slot 0 on pccard0
xe0: Xircom CEM56, bonding version 0x55, 100Mbps capable, with modem
xe0: Ethernet address 00:10:a4:f0:25:62
module_register: module pccard/xe already exists!
linker_file_sysinit "if_xe.ko" failed to register! 17
xe0: watchdog timeout; resetting card

(note - the Xircom card does work, despite the 'watchdog timeout' message)

Any help would be greatly appreciated, and will hopefully save me the
cost of buying another PCMCIA ethernet card! :)



More information about the freebsd-questions mailing list