My sound doesn't work

taxman taxman at
Thu Apr 17 05:55:03 PDT 2003

On Thursday 17 April 2003 04:54 am, Daniel Kives wrote:
> My sound doesn't work.  I've been searching around google, I've tried
> different things still no sound.  This is
> some of my info.  I have a Sound Blaster Live  with Digital Audio
> Output.  I read the handbook, and tried to follow the page about setting
> up the Sound Card.
> I added device pcm to my kernel.  Then I rebuilt the kernel.  Here's my
> output, and it seems my computer
> recognizes the device.
> grep pcm /var/run/dmesg.boot
> pcm0: <Creative EMU10K1> port 0xeec0-0xeedf irq 9 at device 9.0 on pci0
> pcm0: <TriTech TR28602 ac97 codec>

it looks like the kernel sees it just fine, you've set that part up right, it 
appears.  So then check the obvious stuff first.  Are you sure the speakers 
are plugged in right, turned on :), volume up, etc.  Check the output of 
mixer and let us know what that shows.

Also how are you testing the sound?  Do you get errors or just no sound?  Try 
installing a console app like /usr/ports/audio/mpg123 and run it from the 
console and see if you get sound then.  If you have kde (or gnome I think) 
installed they have their sound daemons that can block other programs out 
dependnig on how they are used.  So running from the console wil eliminate 

I don't know why you don't get the midi , but that should not affect how the 
system see the rest of the sound devices.


More information about the freebsd-questions mailing list