X11 printing problem

Stefan Farrenkopf sfarren at gwdg.de
Fri Apr 11 09:26:03 PDT 2003

Hi all,

I solved my problem myself.
The solution was that the x11 apps do obviously not use the same $PATH than 
I do in the shell. After the build of release 4.8 I got new versions of 
lpr, etc. in the /usr/bin directory and they were not able to produce 
output, because I am using cups.
That the printing did not work even before the upgrade is probably another 
problem wich has been solved by the upgrade to the 4.8 release.


--On Friday, April 11, 2003 10:27:43 +0200 Stefan Farrenkopf 
<sfarren at gwdg.de> wrote:

> Hi,
> after I upgraded my ports with portupgrade -ra my system lost the ability
> to print from x11 applications.
> some information about my system:
> 4.8 release now
> (but the printing was broken two days before the upgrade. My hope that
> the upgrade of the base system will solve my problem did not became true
> :( ) X11 is XFree86-4.3.0,1
> gnome2 Desktop, but KDE is also installed.
> cups itself seems to work fine. I can print test pages from the Browser
> interface to the daemon (:631). I can also print from x11 apps like
> Mozilla or Mulberry into a file and sent this file from the command line
> to the printer with success. I switched debugging for the cupsd daemon
> on, but when I print from X11 nothing appears in the error.log file.

More information about the freebsd-questions mailing list