mountroot prompt after new install of FreeBSD 4.8

Oscar Ricardo Silva osilva at
Thu Apr 10 09:30:49 PDT 2003

I just installed FreeBSD 4.8 on a Dell PowerEdge 2650 with a RAID 
controller, 5 hard drives.  After the install (which went off without a 
problem), I rebooted the machine and got:

aac0: <Dell PERC 3/Di> mem 0xf0000000-0xf7ffffff irq 16 at device 8.1 on pci4
aac0: i960RX 100MHz, 118MB cache memory, optional battery present
aac0: Kernel 2.7-1, Build 3170, S/N 4441d3

acd0: CDROM <TEAC CD-ROM CD-224E> at ata0-master PIO4
aacd0: <RAID 5> on aac0
aacd0: 38912MB (79691776 sectors)
aacd1: <RAID 5> on aac0
aacd1: 30510MB (62486016 sectors)

Manual root filesystem specification:
   <fstype>:<device>  Mount <device> using filesystem <fstype>
                        eg. ufs:/dev/da0s1a
   ?                  List valid disk boot devices
   <empty line>       Abort manual input


If I then type:

mountroot> ufs:/dev/aacd0s1a
Mounting root from ufs:/dev/aacd0s1a

The machine boots fine.

I've seen many questions about this same problem but no real 
solution.  I've encountered this same problem on other machines but was 
able to solve it by moving the boot drive from ATA66 to ATA33 
controller.  Can't do that here.

So what's going on here?  Why do I get this prompt after a brand new 
install?  I've tried recompiling the kernel and support for the RAID 
controller was built into it.  I've tried creating /boot/loader.conf with 
the content:

rootdev="aacd0s1a"              # Set the root filesystem


More information about the freebsd-questions mailing list