fbtab and cdrom

Markie markie at notwentytwo.freeserve.co.uk
Tue Apr 8 14:25:37 PDT 2003

Probably need to set

sysctl -w vfs.usermount=1

as root :)
Then the users should be able to mount things to any directory which is
owned and executable? by them.


----- Original Message -----
From: "Randy Grafton" <rgrafton at indatacorp.com>
To: <freebsd-questions at freebsd.org>
Sent: Wednesday, April 09, 2003 10:15 PM
Subject: fbtab and cdrom

I've just installed 4.8 and am having some trouble with non-root users
mounting cdroms. I have following entries in /etc/fbtab:
/dev/ttyv0 0640 /dev/acd0c
/dev/ttyv0 0700 /cdrom

and my fstab has:
/dev/acd0c /cdrom cd9660 ro,noauto 0 0

When I log into the console as a standard user and perform: mount /cdrom
The system then responds with an "operation not permitted" message.
My next attempts included changing the ownership on the /cdrom directory and
the /dev/acd0c and changing the permissions on these to 0777. I have also
tried mount_cd9660 /dev/acd0c /cdrom
mount_cd9660 /dev/acd0c /home/{logged-in-user}/cdrom
where /home/{logged-in-user}/cdrom is wholly owned by the logged-in-user.
All attempts have resulted in the same message, "operation not permitted".
However, if I log in as root I have no problems.
I would really like to take the approach of using the fbtab file.
My goal is that a non-root user can log in to the console and execute a
script that mounts the cdrom, copies its contents to a folder on the system
and then unmounts the cdrom.
Any and all help is appreciated.


P.S. I installed the eject program from the sysutils port and tried to
implement it in my script, but I can't get that to behave either. Even
trying it from the command line, the mounted cdrom won't eject.

freebsd-questions at freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list