4.8 mini-iso wont boot off SCSI cdrom

Patrick Salsbury salsbury at sculptors.com
Mon Apr 7 09:37:49 PDT 2003

Hash: SHA1

Content-Type: text/plain; charset=us-ascii

On Saturday 05 April 2003 08:42 pm, C Mead wrote:
- -> Hi all,
- ->
- -> Wondering if anyone has had, or can try to recreate the problem below.
- ->
- -> Just downloaded the 4.8 mini iso, and tried booting it from a Plextor UW
- -> SCSI cdrom, for some reason though it doesnt want to boot from it. The
- -
- -at what point does it fail?  Do you see any messages?
	I've been seeing the same behavior for a few months as I try to get a 
couple of older Pentium boxes installed with FreeBSD. I've got a 200MHz Intel 
Performance/AU motherboard, and Adaptec AHA-2940UW SCSI card, a 2Gb IBM 
SCSI drive, and a 9Gb Seagate one. Also, an old NEC 4-speed CDR-222. 
	I've tried just about every combination imaginable over the past 
couple of months, and more so in a frenzy of determination the past few days. 
I've tried an IDE CD-ROM, with one or the other of the SCSI drives out, by 
booting with floppies, or with a CD-ROM. I've tried it with 4.3 and 4.7 CD's, 
too! The CD-ROM boots right up in my Linux machine, too. The media is fine. 
But it always wedges at exactly the same place:

Copyright (c) 1992-2001 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 4.3-Release #0: Sat Apr 21 10:54:49 GMT 2001
    jkh at narf.osd.bsdi.com:/usr/src/sys/compile/GENERIC
(Stops here....)

	The fourth line varies, depending on which CD I try, but it always 
freezes after the 5th.

	Now the *REALLY* weird thing is... I've found that if I ignore the 
machine, walk away in disgust, or get busy typing a note like this, and leave 
it there at the frozen point for a while, sometimes, after 15 minutes or so, 
it suddenly comes back to life, finishes booting, and greets me with a 
cheerful install prompt. (The first time this happened, I did a basic install, 
so I can now also get to a fully functional system with very snappy response 
and usability...if I don't mind waiting about a half-hour for it to boot. :-)  )
- -> cd works I've booted it on 2 other machines with IDE drives, so its not
- -> the media(cdrom) itself.

- -> And I've booted both Slackware and Gentoo iso's on the scsi cdrom and
- -> they boot fine as well.
	Also ditto. I was able to install RedHat 8.0 on the 9Gb disk long 
before I discovered the half-hour-wait trick and was able to install 4.3 on 
the 2Gb disc. 

- -> I have just stuck a old IDE cdrom in the SCSI box and it boots the
- -> install fine from that drive.
- -
- -we need the output of the boot messages to be able to figure out why and see 
- -what hardware you have.  Boot with the IDE drive then use a fixit floppy 
- -ftp://ftp.freebsd.org/pub/FreeBSD/releases/i386/4.8-RELEASE/floppies/fixit.flp
- -to save the output of dmesg.  That needs to be written as an image to a 
- -floppy.  See the install instructions in the handbook for how.
- -
- -Or just install using the IDE cdrom and copy the text from the file 
- -/var/run/dmesg.boot

	...Or just type it in while waiting! :-) You have my output above. And 
just on cue, the system came back to life and has resumed its boot! It's 
pausing for a minute or two at sendmail, then it'll finish up. Guess I'll go 
play for a bit. 

	Anyone have clues or ideas about this? I just flashed my Adaptec BIOS 
to the 2.20 version. Going to do the motherboard next. I've read about 200 web 
pages and posts in the past 2 days about this, and it seems that a LOT of 
people are having problems surrounding the 2940 and/or SCSI CD-ROMs in 
	I'm still new to FreeBSD, but I like what I've seen so far. Just wish 
I could get it to work on my machines... :-) 

	Any replies are appreciated. I'm not (yet) on this list, so I'm not 
even sure if my post will go through. Gotta get back to it... 

	   ___________________Think For Yourself____________________
	 Patrick G. Salsbury - http://reality.sculptors.com/~salsbury/
			Learn about stereolithography:
      "Wisdom is not communicable.  The wisdom which a wise man tries to
       communicate always sounds foolish" -- Herman Hesse, _Siddhartha_

Version: GnuPG v1.0.7 (GNU/Linux)
Comment: Don't know what GPG is? Check http://www.pgpi.org/


More information about the freebsd-questions mailing list