PPPoE not working

E. J. Cerejo edinho64 at netscape.net
Fri Apr 4 16:02:49 PST 2003

I have a weird problem here with PPPoE, I had it working with this 
configuration before I bought a belkin router:

  set log Phase Chat LCP IPCP CCP tun command
  nat enable yes
  nat same_ports yes
  nat use_sockets yes
  set redial 15 28800
  set reconnect 15 28800

  set device PPPoE:fpx0: <-- I also tried without this colon.
  set mru 1492
  set mtu 1492
  set speed sync
  enable lqr
  set lqrperiod 5
  set cd 5
  set dial
  set login
  set timeout 0
  set authname xxxxxxxxx
  set authkey xxxxxxxxx
  set ifaddr
  add default HISADDR
  enable dns

then I stopped using pppoe when I went behind the belkin dsl wireless 
router and now I wanted to test some windowz internet apps that run with 
wine (like winmx) which can't resolve the servers, they work if you 
enter the correspondent IP number for that server.  So I went ahead and 
unhooked the dsl/router and connceted my box straight to the modem, I 
commented out 3 lines in my rc.conf which related to my belkin router. 
Restarted and and tried to connect, it creates a tun0.pid but can't 
browse because it looks like it didn't connect at all, I ran ifconfig 
and here's the results:

fxp0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 1500
    ether 00:20:ed:ab:7a:c9
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
lp0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
ppp0: flags=8010<POINTOPOINT,MULTICAST> mtu 1500
sl0: flags=c010<POINTOPOINT,LINK2,MULTICAST> mtu 552
faith0: flags=8002<BROADCAST,MULTICAST> mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x6
    inet netmask 0xff000000
tun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1500
    Opened by PID 156

I get no IP address.  Not only that but when I startx, it freezes as if 
it needed an IP address.  Anyone has any idea why this happens?

I also have these 4 options in my kernel:

options         NETGRAPH
options         NETGRAPH_ETHER
options         NETGRAPH_SOCKET
options         NETGRAPH_PPPOE

More information about the freebsd-questions mailing list