VMware2 build under -CURRENT ... is Broken?

Garance A Drosihn drosih at rpi.edu
Thu Apr 3 15:10:08 PST 2003

At 3:49 PM -0700 4/1/03, Danilo Fiorenzano wrote:
>5.0-CURRENT with sources cvsup'd on March 30.
>"portinstall vmware2" aborts with:
>.../vmmon-only/freebsd/hostif.c: In function `FindMPN':
>.../vmmon-only/freebsd/hostif.c:186: invalid operands to binary >>
>*** Error code 1
>Stop in /usr/ports/emulators/vmware2/work/vmware-distrib/vmmon-only.
>  Just wondering if the port is actually currently broken under
>-CURRENT or if it is something with my system.  I would like to
>know if it builds OK for other people tracking HEAD.

It happens that I rebuilt the vmware2 port on my machine on
March 25th.  That went OK.  Just now I tried a force-rebuild of
it, and I see the same error that you reported.  So, it looks
like something has changed in the system includes, and that
is confusing the vmware2 port.  (I say "in the system", because
the vmware2 port itself has not changed since I last built it).

There were a number of other compile-time warnings before the
one you listed.  My guess is that /sys/sys/param.h might be
getting pulled into the compile when it did not used to be
pulled into it, but that is a very shaky guess.

Please note that I am not likely to look into this any farther,
because what I think I finally determined is that vmware2 simply
does not work on my new PC (it builds fine, but crashes when I
try to run it, on both stable and current).  I still run it on my
older PC, but that PC is running freebsd-stable, and needs to
stay that way for now.

Garance Alistair Drosehn            =   gad at gilead.netel.rpi.edu
Senior Systems Programmer           or  gad at freebsd.org
Rensselaer Polytechnic Institute    or  drosih at rpi.edu

More information about the freebsd-questions mailing list