Loopback filesystem support?
blueeskimo at gmx.net
Thu Apr 3 08:11:24 PST 2003
On Thu, 2003-04-03 at 00:52, Rus Foster wrote:
> Hi All,
> Does FreeBSD have any support for loopback filesystems. i.e. I mean being
> able to mount a file as a filesystem ala Linux. Googling didn't chuck back
> much and the nearest I found was mount_null. Is it possible?
-$ man mount_null
MOUNT_NULL(8) FreeBSD System Manager's Manual
mount_null - mount a loopback filesystem sub-tree; demonstrate the
use of a null file system layer
THIS FILESYSTEM TYPE IS NOT YET FULLY SUPPORTED (READ: IT DOESN'T
WORK) AND USING IT MAY, IN FACT, DESTROY DATA ON YOUR SYSTEM. USE AT
YOUR OWN RISK. BEWARE OF DOG. SLIPPERY WHEN WET.
This code also needs an owner in order to be less dangerous -
serious hackers can apply by sending mail to <hackers at FreeBSD.org> and
announcing their intent to take it over.
mount_null is all that exists for a loopback filesystem in FreeBSD
(afaik), and it does have many sharp edges (I actually once lost ~30gb
b/c of it). I'd avoid it at all costs. Try using symlinks instead, if
Adam <blueeskimo at gmx.net>
More information about the freebsd-questions