Sony VAIO w/ Linksys card

Terry Tyson ttyson at
Tue Apr 1 21:27:15 PST 2003

I don't think it is a hardware problem. I have the same laptop (currently
out of the office). It has a Linksys EtherFast 10/100 Integrated PC Card.
When I was dual booting with Win98 and Mandrake9.0, the card worked fine
with both OS. I changed to Win98 and FBSD4.7. The card still works under
Win98 but haven't got it configured correctly yet in FBSD. The hardware page

Linksys EC2T/PCMPC100/PCM100, PCMLM56, EtherFast 10/100 PC Card, Combo
PCMCIA Ethernet Card (PCMPC100 V2)

under the section:

NE2000 compatible PC-Card (PCMCIA) Ethernet and FastEthernet cards ( ed(4)

When the laptop comes back from the field (2 weeks), one of our IT guys
(more familiar with FBSD) is going to help me configure the driver. Will let
you know how it goes. Hopefully someone else will have better answers before

BTW, are you running X? I am having trouble getting it set up right.



-----Original Message-----
From: owner-freebsd-questions at
[mailto:owner-freebsd-questions at]On Behalf Of Adam Lofstedt
Sent: Thursday, March 27, 2003 6:08 PM
To: 'Rodney Salomon'
Cc: freebsd-questions at
Subject: RE: Sony VAIO w/ Linksys card

> Hello,
> I'm trying to install FBSD on a Sony VAIO PCG-F350. I
> have a Linksys
> card in it. FBSD doesnt seem to recognize the Linksys
> card during the
> installation. Dont know why? Also, after installation,
> I added
> "pccard_enable..." to the /etc/rc.conf file.... now,
> it does see the
> card but, it see's it as ed1 device and it doesnt come
> up till after
> the boot is complete and im at a login prompt....
> thats when it beeps
> and it gives me a "ppcard started...." message, and I
> have to hit
> enter to get the login prompt back. Any help on this
> situation would
> be greatly appreciated.

I think it is a problem with the Sony not giving access to the PC card.
I've tried similar things with the PCG-F series notebooks and a variety
of different PC network cards, with no luck.

I've tried without fail to use symantec ghost on the F series, which
uses a DOS boot disk to boot to a DOS program that uses the Network
card.  On other machines such as Dells, Toshibas, etc, it works just
fine, but on the Sony F series the NIC is never detected.  This was a
big clue to me that it must be some kind of hardware limitation with the
Sony F series.

I gave up trying to do anything with a Sony F series and a network card
before an OS has fully booted up.

That's just my experience, maybe someone else will have a better answer
than me...

Adam Lofstedt

freebsd-questions at mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list