make buildworld help!!?!?!?!!

Brent Bailey misterb at
Tue Apr 1 07:24:10 PST 2003

Hello, Im running a FBSD 4.5 machine DUEL CPU 450 w/ 512 MB ram . Anywho
..i tried to CVSUP to the latest stable release , seems the CVSUP went
well ...ANYWHO my problem after all was said and done was that i cant do a
"ps -ax"  or "w" or "top"
this is the procedure i did with no good results:

make a backup of etc
cp -Rp /etc /etc.old

in a prebuild world environment
# /usr/sbin/mergemaster -p -v

# cd /usr/obj
# chflags -R noschg *
# rm -rf *

Compile the sources:

# cd /usr/src
# make buildworld  <-- this failed the first time something to do with
sendmail i removed * from    the
/usr/local/etc/cvsup/sup/refuse file so it would ignore sendmail
then did a "cleandir" and then redid CVSUP and then redid
make buildworld

Compile and install the new kernel:

# cd /usr/src
# make buildkernel KERNCONF=LOQTIS-SMP-1  <-- this failed to  saying it
couldnt make LOQTIS-SMP-1   although it said it made the GENERIC kern. go
At this point i didnt know what to do i just continued
i rebooted into single user mode and ran:

#make installworld   <-- no errors

#/usr/sbin/mergemaster -v    <-- from what i understand if you select "d"
it deletes the temporary file, if you select "i" it installes the new
version  of the file. what i did was any file that I knew to be modified
by me i did a "d" to keep my original file and the rest that i knew wasnt
modified by me ...i chose "i" to install the new version.
then I did
# cd /usr/src/release/sysinstall
# make clean
# make all install

when i rebooted i ran into the problem of not being able to do a
"ps -ax" or a "w"  ... i know this means that the make buildworld didnt
work or at least a part of it didnt work right.
Please ..any help or suggestions would be greatly appreciated a note
i did this same procedure on another non-production FBSD 4.5 box with no
issues. also ..i have tape backup of the whole system so if all else fails
i can go back ..but id rather not concidering the recent expoits found in
certain ports im running.Figures huh...

Thank you

More information about the freebsd-questions mailing list