[Bug 204972] net/samba42: conflicting Python dependencies

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Thu Apr 14 11:35:50 UTC 2016


Miroslav Lachman <000.fbsd at quip.cz> changed:

           What    |Removed                     |Added
                 CC|                            |000.fbsd at quip.cz

--- Comment #2 from Miroslav Lachman <000.fbsd at quip.cz> ---
I run in to this problem too. 
Can somebody with proper knowledge look in to this problem?

I have python=3.4 in make.conf and want to build samba42. I tried it in
poudriere. I don't know why py34-dnspython-1.12.0 is installed instead of
py27-dnspython-1.12.0 which is required.

===>   samba42-4.2.7_2 depends on package: p5-Parse-Pidl>=4.0.0 - found
===>   Returning to build of samba42-4.2.7_2
===>   samba42-4.2.7_2 depends on package: py27-dnspython>=1.9.4 - not found
===>   Installing existing package /packages/All/py34-dnspython-1.12.0.txz
[10_2_amd64-default-global-job-01] Installing py34-dnspython-1.12.0...
[10_2_amd64-default-global-job-01] `-- Installing python34-3.4.4_1...
[10_2_amd64-default-global-job-01] |   `-- Installing libffi-3.2.1...
[10_2_amd64-default-global-job-01] |   | `-- Installing indexinfo-0.2.4...
[10_2_amd64-default-global-job-01] |   | `-- Extracting indexinfo-0.2.4: ....
[10_2_amd64-default-global-job-01] |   `-- Extracting libffi-3.2.1: ..........
[10_2_amd64-default-global-job-01] `-- Extracting python34-3.4.4_1: ..........
[10_2_amd64-default-global-job-01] `-- Installing py34-setuptools34-20.0...
[10_2_amd64-default-global-job-01] `-- Extracting py34-setuptools34-20.0:
.......... done
[10_2_amd64-default-global-job-01] Extracting py34-dnspython-1.12.0: ..........

You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

More information about the freebsd-python mailing list