FreeBSD ppc 12.1 & iMac PowerPC G3 DV

steve caturan info at
Thu Mar 26 19:13:43 UTC 2020

Howdy all,

Just recently got an iMac G3 DV 400Mhz and I want to repurpose it to run
FreeBSD as light-weight server at home (rsync, squid, reverse SSH tunnels,
et al)

Hardware Overview:

PowerMac 2,1
PowerPC 750 (83.2)
Boot ROM Version: 4.1.9f1
RAM: 384MB
CPU Speed: 400Mhz

Here's what I have tried.

Used the ppc (boot only) ISO of FreeBSD 10.4, 11.1, 11.2, 11.3 (all
-RELEASE) to boot off a CD - it goes through orange screen with all OFW
stuff, I hit Enter then it  goes through the boot process but then all of a
sudden, the machine reboots. All 4 major releases render the same results.

In terms of booting off a CD with all the attempts I've made to get into
the FreeBSD installer, I tried the built-in slot-loading drive and an
external CD/DVD drive (USB).

FreeBSD 12.1-RELEASE, -STABLE and 13-CURRENT gets stuck but doesn't reboot
and halts. Links to screen shots are below:

I know this is unrelated,  but I managed to install OpenBSD 6.6 ppc on the
same machine using the same booting method.

Please advise as to what I should do to move forward. I'm a novice FreeBSD
user and have a lot of patience.

Thank you, and much appreciated.


More information about the freebsd-ppc mailing list