The PowerMac G5 internal hard disk SATA question

Mark Millard marklmi at
Fri Nov 16 23:14:11 UTC 2018

On 2018-Nov-16, at 13:24, Dennis Clarke <dclarke at> wrote:

> On 11/15/18 5:40 PM, Mark Millard wrote:
>> On 2018-Nov-15, at 13:07, Dennis Clarke <dclarke at> wrote:
>>> On 11/15/18 11:43 AM, Justin Hibbits wrote:
>>>> On Thu, 15 Nov 2018 11:18:43 -0500
>>>> Dennis Clarke <dclarke at> wrote:
>>>>> Someone (offlist) asked if my shiney new Seagate hard disk was
>>>>> compatible with SATA-I and I wouldn't know. I have had various types
>>>>> of hard disks in this thing and also some SSD types. Nothing is very
>>>>> fast and all of them worked.
>>>>> Not sure if anyone else has tried to attach a new Samsung EVO SSD
>>>>> onto an old PowerMac G5 but I would be interested to hear the
>>>>> results. In the mean while I will figure out how to fully backup the
>>>>> contents of my old Apple branded Hitachi Deskstar HDS725050KLA360
>>>>> 500GB disk which has a very stable Debian sid PPC64 image on it. I
>>>>> figure dd will do the trick.
>>>>> If there is a way to install FreeBSD from a USB stick onto a PowerMac
>>>>> G5 well I'd love to hear from someone about the OpenFirmware magic
>>>>> needed. Thus far using a PC keyboard and a Vulkan nerve pinch
>>>>> CTRL+O+F does not get me to the openfirmware prompt. It has been a
>>>>> while since I tried and it may need a six fingered vulkan hand to do
>>>>> CTRL+SHIFT+O+F to work.

Have you found a way to get to the Openfirmware prompt?
Someone may know of things to check for or reset from the

>>>>> Then boot ud:,\\:tbxi ???
>>>>> Dennis
>>>> Hi Dennis,
>>>> My experience with the Samsung EVO drives on PowerMac G5 is they only
>>>> seem to work on the second (bottom) SATA interface.  I have yet to
>>>> figure out why, but both my 840EVO and 850EVO behaved that way.  It
>>>> works more or less fine there.  Sometimes my G5 would forget about it
>>>> at boot, and I'd have to power cycle in order for it to recognize the
>>>> drive again.  It never once worked in the 'primary' slot.
>>> OKay this is helpful !  Thank you. I thought I was losing my mind ( what
>>> there is to lose ) in that I was getting weird behavior from my disks or
>>> ssds in these old boats.  Could just be bizarre Apple hardware.
>>> I think what I shall do is boot ye old original Apple label Hitach disk and then do a backup to an external USB attached brick. That way I have
>>> all my Debian sid ppc64 work saved away. Maybe I will fire up another G5
>>> brick but those damn things really put a drain on the UPS for what they
>>> do. Perhaps QEMU will be okay for my Debian sid ppc64 work. Regardless I
>>> have greater interest in FreeBSD UNIX and I realyl would like to have at
>>> least two or three risc machines running.  Namely RISC-V and PPC64 and a
>>> SPARC unit for local flavour. I have a ton of SPARC laying about. Also a
>>> metric ton of PA-Risc HP Superdome gear in my life. However that is a
>>> whole other story and only Helge Deller could make those work.
>>> So anyways ... I will try with the original Apple part disk in the
>>> correct slot and then there are no excuses.
>> Were I long-ago got the SSDs that I use in the PowerMac G5s
>> used to list compatibility extensively, case by case, for
>> they're products vs. direct use in various Apple systems.
>> But it had an interesting summary after looking through the
>> information for G5's (from memory):
>> asynchronous NAND: compatibile
>> synchronous  NAND: problematical/incompatible
>> All the SSDs that I use in the G5's are based on asynchronous
>> NAND. At this point, they are all old.
>> That company no longer sell SSDs that they classify as
>> compatible with PowerMac G5's.
> I have abandoned SSD's entirely as problematic and just another variable
> that is not worth having in the situation. Also I will thank Justin
> Hibbits for some hints here that perhaps the upper SATA connector is
> somehow different from the lower connector.

I've been lucky and never used a device with such a
distinction showing up.

>    Seagate ST3000DM001  installer seems happy and machine will
>                         not boot.  I get a white screen that
>                         seems confused :

Not that it helps solve the problem (and you may well
know already), but the white display of:

> ofw_close: devh=0x0
> >> FreeBSD/powerpc Openfirmware boot block
>   Boot path:   /ht at 0,f2000000/pci at 9/k2-sata-root at c/@0/@0:
>   Boot loader: /boot/loader
>   Boot volume:   /ht at 0,f2000000/pci at 9/k2-sata-root at c/@0/@0:3

is from Apple's Openfirmware --or at least is from
before FreeBSD materials change the display: very
early. It suggests the initial transition out of
Openfirmware did not get very far at all.

I've never had boot problems that were this early
as far as I can remember. I always got past the
display change (to a black background), if I
remember right.

> Then nothing happens and after four or five minutes the fans kick into a
> higher gear and I remove the power cord.
> So I will move on to Seagate ST2000DM001 and also a small "Enterprise"
> Seagate ST2000NX0243 and lastly the original Apple Hitachi HDS725050KLA360.
> The small ST2000NX0243 will be a disaster given that it is native 4K
> sectors only. Great for an array but not so great for older equipment.
> This is all taking a lot of time with zero progress thus far.

Mark Millard
marklmi at
( went
away in early 2018-Mar)

More information about the freebsd-ppc mailing list