after running the installer on a PowerMac G5 no root filesystem found

Mark Millard marklmi at
Wed Nov 14 17:52:20 UTC 2018

On 2018-Nov-14, at 09:15, Michael Tuexen <Michael.Tuexen at> wrote:

>> On 14. Nov 2018, at 18:02, Justin Hibbits <chmeeedalf at> wrote:
>> On Wed, 14 Nov 2018 11:52:45 -0500
>> Dennis Clarke <dclarke at> wrote:
>>> <snip>
>>>>>> At first boot I get a load of text and then a strange prompt that
>>>>>> seems to be asking where is the root filesystem? It also lists
>>>>>> all the various filesystems found. I tried to enter
>>>>>> ufs:/dev/adas2 and similar things but this gets me nothing but an
>>>>>> unrecognized filesystem message.
>>>>>> So .. something obvious?  
>>>>> Can you try setting the variable kern.smp.disabled to 1 at the
>>>>> loader prompt?
>>>>> If that helps, you can add
>>>>> kern.smp.disabled=1
>>>>> to /boot/leader.conf  
>>>> I meant /boot/loader.conf.  
>>> To do that at all I would need to be able to get to the root
>>> filesystem.
>> You can do it at the loader.
>> set kern.smp.disabled=1
>> boot
>>>>> I had all sorts of problems until I disabled SMP on my G5
>>>>> PowerMacs. Without SMP they are running very stable.  
>>> So FreeBSD can not run on ye old IBM PPC970 units with multiple cores
>>> or multiple sockets?  That sounds like a critical bug.
>> It could until recently, due to my fault.  I can revert the change that
>> caused it, but haven't yet, because I don't understand why it's causing
> I think I tried a kernel with you change reverted. It didn't fix the
> problem. I can try again, but at that time the problem was not only
> related to the one commit.

I'm still running with smp based on head -r339076 ( between ALPHA8 and
ALPHA9) with smp on both G5 Quad Core (system total cores), 16 GiBytes
RAM and 12 GiBytes RAM, and on G5 Dual processor, 8GiBytes RAM. (Same
SSD moved between machines.) But I reverted the change Justin is
talking about in order have smp working. I did not have to change
anything else.

# svnlite diff /usr/src/sys/powerpc/include/vmparam.h
Index: /usr/src/sys/powerpc/include/vmparam.h
--- /usr/src/sys/powerpc/include/vmparam.h	(revision 339076)
+++ /usr/src/sys/powerpc/include/vmparam.h	(working copy)
@@ -107,7 +107,7 @@
 #ifdef __powerpc64__
 #define	VM_MIN_KERNEL_ADDRESS		0xe000000000000000UL
-#define	VM_MAX_KERNEL_ADDRESS		0xe0000007ffffffffUL
+#define	VM_MAX_KERNEL_ADDRESS		0xe0000001c7ffffffUL

That revert was to have the "before -r334498" content for that file.
Andreas Tobler reported confirming my findings in his context.

I note this mostly because Justin has reported no longer having such a
machine to test on.

[I am slowly working on updating to 13.0 FreeBSD all the FreeBSD machines
that I have ready access to. The powerpc families will be last.]

>> the problem.  And I'm pretty confident it's not causing the mountroot
>> issue (though, I was pretty confident it wouldn't cause any problem
>> anyway, but that turned out to be false confidence).

FYI: I never saw such an issue for as far as I've gotten with the

Mark Millard
marklmi at
( went
away in early 2018-Mar)

More information about the freebsd-ppc mailing list