Mac mini and FreeBSD - some initial details

Garance A Drosihn drosih at
Sun Jan 23 19:55:06 PST 2005

At 5:29 PM -0500 1/21/05, Garance A Drosihn wrote:
>I can use a Mac-mini for other purposes if it does not work out with
>FreeBSD/PPC, so I'm going to try to get up early tomorrow to see if
>I can get to the local Apple Store early enough to pick one up.  If I
>succeed at that, I'll let people on this list know how well I make
>out with FreeBSD/PPC on it.

Well, I did get it going.  There are a lot of things that I am
tempted to do with it, but I thought I should first jot down a few
notes while I still remember some of the details.

I started with the ISO image that Peter Grehan recently created:

It happens that I do all my cd-burning on MacOS 10, and for some
reason the Disk_Utility app on MacOS 10 crashes with that ISO image.
I bought a copy of "Toast 6 Titanium", and that was able to burn the
CD without any problems.

I bought the Mac-mini which has a 1.42GHz G4 processor, and an "80-gig"
hard disk (it's really about 74.5 gig).  The first thing I did was to
boot up off the MacOS 10 installer disk, and use the disk utility on
that (which is a menu item in the MacOS 10 installer program) to
re-partition the disk.  I created one 15-gig partition which would be
'/' for FreeBSD, and one 5-gig one which would be swap for freebsd, and
a few others for the things I want to do with MacOS 10 itself.  Note
that the MacOS 10 Disk Utility has some bugs in it when you start playing
around with multiple partitions and changing their sizes.  Depending on
what you do, and what order you do it in, the program will end up
"losing" a few gigabytes of the disk.  I guess I should bug Apple about

I made a point of picking different sizes for the various partitions
that I created, so that it would be easy to recognize which-was-which
when I would see them in disklabel during the install process.

When I tried to do the FreeBSD install, it could boot up off the CD
fine, but when it came time to select an "install media", it could
not recognize the CD/DVD drive.  So, before doing the install, I used
'tar' to duplicate the contents of the CD to ~ftp/pub/ppc on one of
my other FreeBSD machines (a machine which was already set up to do
anonymous FTP).  The root of the CD includes a symlink to itself, so
you don't want to do a simple 'cp -rp' to duplicate it...

At that point, I'm ready to try the install.  I put the CD into the
Mac-mini, and rebooted the machine.  I held down the 'C' key while
the machine was starting up, and it booted right up into the FreeBSD
installer.  I did a standard install.  I found the partition which I
had created for FreeBSD (in my case it was 'ad0s5'), and created a
partition there, naming it '/'.  I found the partition I had created
for swap, and told disklabel to use that for swap.  I then 'q'uit out
of that.

When asked what packages I wanted to install, I selected 'Developer'.
It asked me if I wanted the ports collection.  Apparently the CD does
not have the ports collection on it, so you might as well say 'no'

It asked for the installation media.  I selected 'FTP', and then
selected 'my own host' (or whatever the option is), where you type
in a URL.  So, I wanted a URL something like:

However, I found that if I typed in the real hostname for that URL,
then the whole installation process would later hang up while trying
to look up that hostname.  So, I found that I had to type in the IP
address there, instead of the hostname.

After you type in the URL, the install process wants to initialize an
ethernet interface.  It gave me a list with the following options:

     fwe0     - FireWire Ethernet emulation
     gem0     - <unknown interface type>
     pflog0   - <unknown interface type>

While that "unknown interface type" looks scary, it turns out that
what you want to select is "gem0".  I said 'no' when asked if I
wanted to configure it for IPv6, and 'yes' when asked if I wanted to
try a DHCP config.  The DCHP config seemed to work okay, except that
field for the hostname was not filed in.  (everything else was,
including the correct information for the domain name).  I looked up
the correct hostname for the IP address that it had gotten (*), and
then okay'ed that configuration.

It downloaded the files, installed everything, and I could reboot
the system.  Further information on what you might want to do at that
point are described in:

[ * - each time I tried this, the machine would get a different IP
address from DHCP.  What hostname did it happen to get for the
attempt were everything worked?    ""...  ]

Garance Alistair Drosehn            =   gad at
Senior Systems Programmer           or  gad at
Rensselaer Polytechnic Institute    or  drosih at

More information about the freebsd-ppc mailing list