net/xrdp: Issue(s) with Channels/Clipboard.

Janky Jay, III jankyj at
Wed Jun 5 13:56:40 UTC 2019

I think I may have found an/the issue here.

Comparing two systems (one that works and one that does not), I noticed
that "/usr/local/sbin/xrdp-chansrv" was not even running on system that
wasn't working. So, I manually ran it to find it was missing some
libraries which I checked with "ldd":

#~ ldd /usr/local/sbin/xrdp-chansrv

/usr/local/sbin/xrdp-chansrv: => /usr/local/lib/xrdp/ (0x800267000) => /usr/local/lib/ (0x800280000) => /usr/local/lib/ (0x80028a000) => /usr/local/lib/ (0x8002a7000) => /usr/local/lib/ (0x8002af000) => /usr/local/lib/ (0x8002bc000) => not found (0) => /usr/local/lib/ (0x8003fd000) => not found (0) => /lib/ (0x80046f000) => /lib/ (0x80049a000) => /usr/lib/ (0x800787000) => /lib/ (0x80081c000) => /usr/local/lib/ (0x800c0f000) => /usr/local/lib/ (0x800c23000) => /usr/local/lib/ (0x800c2f000) => /lib/ (0x800c58000) => /usr/local/lib/ (0x800c8a000) => /usr/local/lib/ (0x800c8f000)

Here, I noticed that both "libfdk-aac" and "libmp3lame" are missing
which is keeping xrdp-chansrv from starting. I was able to install
"fdk-aac-2.0.0" via "pkg install" without any issues but installing
"audio/lame" does not appear to be an option via "pkg". Apparently,
there is a licensing issue. So, this needed to be built from ports. I
would imagine that these are important to people using sound (I am not)
so some audio dependencies should remain. However, I'm not sure it
should be "audio/lame" if there is not a package available for it.
Perhaps finding an alternative or removing it as a dependency from the
xrdp-devel package? Not sure.

Anyhow, getting these two libs installed fixed the chansrv timeout issue
for me. So, hopefully that can help troubleshoot the package install of
xrdp-devel (I haven't tried the port but I'd imagine it probably works

Janky Jay, III

On 5/8/19 4:00 PM, Janky Jay, III wrote:
> Hello Koichiro,
>     Is there any update to this? I've since upgraded both systems to
> FBSD 12.0-RELEASE-p3 and there have also been (I think) two (2) xrdp
> port/pkg updates as well but the problem still remains the same.
> Connections to chansrv work 100% of the time on one system and 0% of the
> time on the other.
>     Also, can you please provide a link to the GH post/report that you
> created? I'd like to take a look and follow that as well if I can.
> Thanks again!
> Regards,
> Janky Jay, III
> On 2019-02-17 12:23, Janky Jay, III wrote:
>> Hello Meta,
>> On 2/16/19 6:37 PM, Koichiro Iwao wrote:
>>> On Fri, Feb 15, 2019 at 11:31:36AM -0700, Janky Jay, III wrote:
>>>> 	This also causes the connection to take 16 seconds to open XFCE4 once
>>>> it finally gives up on channels. I see 4 errors so I'm guessing there's
>>>> a 4 second timeout between attempts. Something similar to the
>>>> issue/recommendation reported at
>>>> I've tried the
>>>> recommended disallowing of channels to see if it would connect faster
>>>> but it does nothing. Still attempts the connections to "chansrv" and
>>>> takes 16 seconds.
>>> I don't think that is recommended in the upstream issue. Just he reporter
>>> tried as workaround. Who recommended? As commented in the ticket, disabling
>>> all channels don't stop connecting to chansrv. That's why *not to
>>> connect when all channels disabled* feature is suggedted.
>>     I should have worded that differently. I suppose "recommended" was
>> incorrect. It was just a thought to see whether or not
>> disable/re-enabling might give me more insight into what was happening
>> via the logs (I tried adding the DEBUG log line to sesman.ini as well
>> but there was no relevant information).
>>> I know some people have the same issue and already recoeded to upstream
>>> GH issue. Hang tight. If I need to know more detail of reproduction,
>>> I might ask you help.
>>> I also reproduce the issue but not 100%.
>>     Sounds good! I can reproduce 100% of the time on one system right
>> now so if there is anything I can do to help, I will certainly do that.
>> Thank you!
>> Regards,
>> Janky Jay, III

More information about the freebsd-ports mailing list