WRKDIRPREFIX='' on command line stops to work?

Lev Serebryakov lev at FreeBSD.org
Thu Oct 19 15:05:56 UTC 2017

 I have WRKDIRPREFIX=/usr/local/build/ports set in my /etc/make.conf
because my /usr/ports is not on FS which I want to torture with builds.
It worked for many years and works now.

 When I need to build port in ports tree in my home directory (for
example, when I test port update) I use

% make DISTDIR=/usr/home/lev/distfiles WRKDIRPREFIX=''

 And it worked until recently. Now I get:

% make DISTDIR=/usr/home/lev/distfiles WRKDIRPREFIX=''
make[1]: don't know how to make

make[1]: stopped in /usr/home/lev/FreeBSD/ports/sysutils/nut
*** Error code 2

make: stopped in /usr/home/lev/FreeBSD/ports/sysutils/nut

  What happens and what should I do?

// Lev Serebryakov

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 963 bytes
Desc: OpenPGP digital signature
URL: <http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20171019/ff7848b7/attachment.sig>

More information about the freebsd-ports mailing list