Crashing chromium/iridium

G. Paul Ziemba pz-freebsd-ports at
Sat Oct 7 21:12:47 UTC 2017

jonc at (Jonathan Chen) writes:

>On 7 October 2017 at 08:39, Grzegorz Junka <list1 at> wrote:
>> Just wanted to check if anybody else observed this annoying behaviour in
>> Chromium/Iridium browsers. Randomly, in about 10-40% of cases, the new tab
>> hangs loading for 30-60 seconds, after which time the browser shows a dialog
>> that the webpage doesn't load and I can either kill or wait.

>This bug has been around for a very long time:

>There was some anecdotal evidence that it was related to code-caching,
>with a possible workaround, but no fixes for it have been committed.
>The workarounds do not appear to work anymore with the latest updates,

The following applies to FreeBSD 11-stable.

I did not experience the issue with 51.0.2704.84, but have seen it
since chrome 59.0.3071.115. I also tried 60.0.3112.101 and 61.0.3163.100
(more recent versions of the www/chromium port) with no improvement.

Might be an independent bug, but I am also getting a "file not found"
error when I click on "options" for the three different plugins I was
using ("ublock origin", "tabs outliner", and "go back with backspace").
This broken behavior could be fixed temporarily by deleting and then
reinstalling the plugin, but after a day or so it would return.

I found that I could recover from the "some tabs hanging forever" state by:

1. Quit chrome browser
2. Delete cache in ~/.cache/chromium or wherever (I am using
   --user-data-dir=/my/homedir/.config/chrome-myhostname, and
   it appears to affect the path in ~/.cache as well)
3. Delete user data dir (in my case, /my/homedir/.config/chrome-myhostname)
4. Restore Bookmarks file (I copy it via cron every day)
5. Reinstall "ublock origin". I abandoned the other two plugins
   because T.O. couldn't access its configuration and the backspace
   plugin stopped working (grr)

That is a drastic approach because all configuration and state is
lost, but it did seem to overcome the hanging tab problem. It makes
me think that there is some persistent state in chrome's user directory
that is related to this issue.

I tried building www/chromium 61 with DEBUG, but the build failed, and I
have not pursued it further.
G. Paul Ziemba
FreeBSD unix:
 1:41PM  up 9 days, 23:29, 14 users, load averages: 0.38, 0.35, 0.29

More information about the freebsd-ports mailing list