[RFC] less patches: control the PATH

Kyle Evans self at kyle-evans.net
Fri Oct 6 14:29:30 UTC 2017

On Oct 6, 2017 8:24 AM, "Guido Falsi" <mad at madpilot.net> wrote:

On 10/06/2017 15:11, Baptiste Daroussin wrote:
> Hi all,
> Here is a patch to add a new feature I am willing to get for a while:
> https://reviews.freebsd.org/D12603

> A user can control which binary will be found in the PATH of the build
> easily by adding
> BINARY_RENAME=        source target

> PS2: the BINARY_RENAME variable name sucks, any better name is welcome :)

Suggestions from the top of my head:





(Yes I think "alias" expresses the concept better)

Guido Falsi <mad at madpilot.net>

+1 for BINARY_ALIAS; concise, descriptive, and accurate

More information about the freebsd-ports mailing list