libGL error: unable to load driver:

Ronald Klop ronald-lists at
Sun May 28 17:51:45 UTC 2017

On Sat, 27 May 2017 18:44:37 +0200, bob prohaska <fbsd at>  

> On an RPI2 www/epiphany finally compiled using portmaster. When started
> it runs (somewhat)  but reports
> libGL error: unable to load driver:
> Web searches suggest it's something to do with an Nvidia driver, which
> seems inapplicable to an RPI2.
> Is there a workaround? /usr/ports are at 441746, /usr/src is at 318674.
> Thanks for reading,
> bob prohaska

AFAIK swrast is the Software Raster driver. So I don't think the link is  
with NVidia in your case.
I had the same error on my laptop with a Radeon driver ( a  
while back, but don't see it anymore when I start a GL program. What I  
remember in my case the error was harmless. The driver was already loaded  
or something like that.
Do you experience actual errors or only the message, i.e. does the program  
run as expected?
I run the latest packages on amd64, but your ports tree is also quite  
up-to-date as far as I see.


More information about the freebsd-ports mailing list