FreeBSD Port: databases/galera [with Mariadb 101]

Bernard Spil brnrd at
Mon Jul 24 11:25:57 UTC 2017

On 2017-03-03 18:35, Калоян Механджийски wrote:
> Hello
> I tried about 1 year ago Galera cluster with MySQL and it didn't work
> out so back then I tried as I tried today MariaDB 101 with Galera
> cluster.
> I see that both Galera and MariaDB ports are being modified but the
> combined configuration don't work at all. I also see that Galera
> cluster is officially supported on FreeBSD.
> I have managed to bring up the cluster and make both nodes join but
> then replication don't work at all and even mysqld process hung when
> trying to stop one of the nodes.
> I have been reading this post
> and I ended up at the same
> place where the author BlindPenguin ended.
> Adding this line 'export LD_LIBRARY_PATH=/usr/local/lib/gcc49' to
> /usr/local/bin/mysqld_safe made the cluster running and nodes able to
> join, but data transfer between nodes don't seem to work.
> I've been trying with various of configuration sets, first tried the
> ones (the most basic ones) from the galera official documentation,
> then I changed some stuff just for troubleshooting but no matter what
> I change I can't get it working.
> My my.cnf file:
> [mysqld]
> binlog_format = 'ROW'
> [galera]
> wsrep_provider="/usr/local/lib/"
> wsrep_cluster_name=MyCluster
> wsrep_cluster_address="gcomm://,"
> wsrep_node_name=MyNode2
> wsrep_node_address=""
> wsrep_sst_method=rsync
> wsrep_sst_auth=sst_user:sudomadafaka
> wsrep_on=ON
> log_basename='galeratest2'
> FreeBSD Version:
> FreeBSD galeratest.mydomain.lan 11.0-RELEASE-p1 FreeBSD
> 11.0-RELEASE-p1 #0 r306420: Thu Sep 29 01:43:23 UTC 2016
> root at  amd64
> My request: Please let me know if anybody from the port maintainers
> did a successful cluster configuration with Galera? After all this
> port is not marked as broken?
> And if I can get any help from the port maintainers , or I should
> probably contact the Galera as port provider?
> Thank you in advance.

This is very strange... That would only work if you replace clang with 
gcc 4.9 in your system and rebuild everything with that.
> LD_LIBRARY_PATH=/usr/local/lib/gcc49

I'm not running clusters myself so it's really hard to test. If you can 
help out, I am interested in actually making this work!

Let me see where I can get with MariaDB 10.2 on FreeBSD 11.1. I will 
probably send you some patch to test.


More information about the freebsd-ports mailing list