java in firefox and jnlp launch - help needed.

Grzegorz Junka list1 at
Mon Jul 4 08:14:00 UTC 2016

On 04/07/2016 07:22, Wojciech Puchar wrote:
> i don't normally use java but have to for starting server remote 
> management.
> i use firefox and installed icedtea-web.
> this page
> executes icedtea plugin and shows java is working properly.
> Now i want to start remote console. it downloads launch.jnlp file.
> i tried to run it with itweb-javaws and after loading software i'm 
> getting
> no iKVM64 in java.library.path
> any idea? Thanks
> _______________________________________________
> freebsd-ports at mailing list
> To unsubscribe, send any mail to "freebsd-ports-unsubscribe at"

Forget about icedtea-web. You will need the official Oracle JDK 
java/linux-oracle-jdk18, which only works through Linux emulation. On my 
system it installed java/javavmwrapper to which javaws points to:

root at crayon2:~ # which javaws

root at crayon2:~ # l /usr/local/bin/java
lrwxr-xr-x  1 root  wheel  21  2 Mar 01:08 /usr/local/bin/java -> 

root at crayon2:~ # pkg which /usr/local/bin/javavm
/usr/local/bin/javavm was installed by package javavmwrapper-2.5

I tried to configure the jnlp file to work with icedtea-web but 
unsuccessfully. Please let us know if you manage to do it.


More information about the freebsd-ports mailing list