error upgrading graphics/dri port "/usr/local/llvm36/bin/clang: not found"

Graham Menhennitt graham at menhennitt.com.au
Tue Jan 19 00:20:59 UTC 2016


On 19/01/2016 6:31 AM, Brooks Davis wrote:
> On Sun, Jan 17, 2016 at 07:08:14PM +1100, Graham Menhennitt wrote:
>> Does anybody have any clues, please?
>>
>> Thanks,
>>      Graham
>>
>> root at starker# portupgrade -aWw
>> [Reading data from pkg(8) ... - 854 packages found - done]
>> --->  Upgrading 'dri-11.0.7_1,2' to 'dri-11.0.8,2' (graphics/dri)
>> --->  Building '/usr/ports/graphics/dri'
>> ===>   dri-11.0.8,2 depends on executable: makedepend - found
>> ===>   dri-11.0.8,2 depends on package: libclc>=0.0.r222830 - not found
>> ===>  Building for libclc-0.1.0.20150710
>> [8/979] LLVM-CC r600--/lib/math/mad.cl.cedar.bc
>> FAILED: /usr/local/llvm36/bin/clang -MMD -MF
>> r600--/lib/math/mad.cl.cedar.bc.d -target r600-- -I`dirname
>> generic/lib/math/mad.cl` -Igeneric/include -fno-builtin
>> -Dcl_clang_storage_class_specifiers -Dcl_khr_fp64 -Dcles_khr_int64
>> -D__CLC_INTERNAL -emit-llvm -mcpu=cedar -c -o
>> r600--/lib/math/mad.cl.cedar.bc generic/lib/math/mad.cl
>> /bin/sh: /usr/local/llvm36/bin/clang: not found
>> ...
> You appear not to have lang/clang36 installed.  I don't know why
> portupgrade isn't installing it since it is a BUILD_DEPEND of
> graphics/dri, but installing it by hand should work around the problem.
>
> -- Brooks
Indeed, it does fix it. Thanks for your help.

Graham


More information about the freebsd-ports mailing list