Problem with package library dependencies after update from 8.4 to 9.3

Paul Keusemann pkeusem at gmail.com
Tue Jan 12 23:33:26 UTC 2016


Thanks for the help Kevin.  See below for responses....

On 01/12/16 14:16, Kevin Oberman wrote:
> On Tue, Jan 12, 2016 at 8:46 AM, Paul Keusemann <pkeusem at gmail.com 
> <mailto:pkeusem at gmail.com>> wrote:
>
>     I am in the process of bringing a neglected FreeBSD 7.2 machine up
>     to a more recent O/S and have run into a problem with package
>     dependencies.  I used the upgrade option in the FreeBSD-8.4-Releas
>     installer to upgrade form 7.2 to 8.4 then used freebsd-update to
>     move to 9.3.  With the move to FreeBSD-9.3 I also converted to the
>     new package system and I now have a number of installed packages
>     that are claiming libgdk_pixbuf-2.0.so.0 as a required shlib but
>     there are no packages that provide it.  It does exist in
>     /usr/local/lib.
>
>     When in run ``pkg check -Bda'' I get a bunch of messages similar
>     to the following:
>
>        avahi-gtk has require a missing libraries: libgdk_pixbuf-2.0.so.0
>        brasero has require a missing libraries: libgdk_pixbuf-2.0.so.0
>        clutter has require a missing libraries: libgdk_pixbuf-2.0.so.0
>
>     I have tried a number of things (from reinstalling to deleting and
>     installing all of the problem packages) to clear this up but
>     nothing has been successful so far.
>
>     At this point, I don't know iflibgdk_pixbuf-2.0.so.0 is necessary
>     or if it should be removed as a requirement. I'd just like to know
>     how to clear this up.
>
>     -- 
>     Paul Keusemann pkeusem at gmail.com <mailto:pkeusem at gmail.com>
>     4266 Joppa Court (952) 894-7805 <tel:%28952%29%20894-7805>
>     Savage, MN  55378
>
>
> Paul,
>
> First, is /usr/local/lib/libgdk_pixbuf-2.0.so.0 found on your system? 
> Is gdk-pixbuf2-2.32.1 installed? If not, install graphics/gdk-pixbuf2. 
> (But read the rest of this first!)

Yes.  It's a symlink to libgdk_pixbuf-2.0.so.0.3200.1.

shiner# ls -l /usr/local/lib/libgdk_pixbuf-2.0.so.0
lrwxr-xr-x  1 root  wheel  29 Jan  8 22:35 /usr/local/lib/libgdk_pixbuf-2.0.so.0@ -> libgdk_pixbuf-2.0.so.0.3200.1


The gdk-pixbuf2-2.32.1 package is also installed but it does not provide 
libgdk_pixbuf:

shiner# pkg info --provided-shlibs gdk-pixbuf2
gdk-pixbuf2-2.32.1:
         libpixbufloader-jpeg.so
         libpixbufloader-png.so
         libgdk_pixbuf_xlib-2.0.so.0
         libpixbufloader-bmp.so
         libpixbufloader-gif.so
         libpixbufloader-xbm.so
         libpixbufloader-qtif.so
         libpixbufloader-icns.so
         libpixbufloader-jasper.so
         libpixbufloader-ani.so
         libpixbufloader-tiff.so
         libpixbufloader-ico.so
         libpixbufloader-xpm.so
         libpixbufloader-pnm.so
         libpixbufloader-tga.so

In fact, none of my installed packages provides libgdk_pixbuf which I 
guess is what pkg is trying so desperately to tell me.

shiner# pkg info --provided-shlibs -a | grep libgdk_pixbuf
         libgdk_pixbuf_xlib-2.0.so.0


Is libgdk_pixbuf_xlib-2.0 a new name for the old dependency that somehow 
is not getting updated?

I guess the question is, what is supposed to provide libgdk_pixbuf. If 
the answer to that question truly is "Nothing." then what should shlib 
those packages be requiring?

>
> The question remains as to why this dependency was not installed, but 
> at least this will get things working.
> Gnome dependencies are  maze of twisty little passages, all different.
>
> After the upgrade, did you re-install all packages/ports? I assume so, 
> but I wanted to be sure. I see a large number of dependencies on 
> gdk-pixbuf2, so I would expect it to be installed, but that may be the 
> result of my use of Mate which is a Gnome2 fork and you may be using a 
> different desktop. In any case, you might want to open a bug on this. 
> If you do, please include an attachment with a list of all of your 
> CURRENTLY installed ports. (In other words, get the list BEFORE 
> installing graphics/gdk-pixbuf2.)

I did.  Several times.  Then I deleted all of them with "pkg delete" and 
re-installed them with "pkg install".  I have also tried "pkg upgrade 
-f".  Still no joy.

>
> I'm afraid I just don't have the time right now to try to walk through 
> all of the dependencies and try to figure out where things went off 
> the rails. Maybe this evening.
> --
> Kevin Oberman, Part time kid herder and retired Network Engineer
> E-mail: rkoberman at gmail.com <mailto:rkoberman at gmail.com>
> PGP Fingerprint: D03FB98AFA78E3B78C1694B318AB39EF1B055683

-- 
Paul Keusemann			                     pkeusem at gmail.com
4266 Joppa Court		                     (952) 894-7805
Savage, MN  55378



More information about the freebsd-ports mailing list