dns-terror (fastresolve-2.10_5) doesn't work on FreeBSD 10.x

Miroslav Lachman 000.fbsd at quip.cz
Fri Jan 1 21:07:54 UTC 2016


olli hauer wrote on 01/01/2016 17:06:
> On 2016-01-01 16:35, Miroslav Lachman wrote:
>> Miroslav Lachman wrote on 10/18/2015 15:45:
>>> Hi,
>>>
>>> I am using dns-terror to resolve IP addresses in Apache logs for many
>>> years on FreeBSD but it doesn't work on newly upgraded machines. It
>>> works fine on 8.4 but core dump on 10.1 and 10.2 amd64.
>>> Tested on 5 machines. Port is compiled on 10.1 or 10.2.
>>>
> ...
>>>
>>> It fails even on simple file like this:
>>>
>>> # cat /tmp/test.log
>>> 1.2.3.4
>>>
>>> Are somebody using dns-terror on FreeBSD 10.x? What can I do to debug
>>> and solve this problem?
>>>
>>> Miroslav Lachman
>>
>> I am still not able to solve this problem. Dns-terror is failing on all our machines with FreeBSD 10.2.
>>
>> 1) Is somebody using it on 10.2 without problems?
>>
>> 2) How can I build it with some kind of debugging? (I am not C programmer, I don't know this stuff)
>>
>> Miroslav Lachman
>>
>
> Hm, fastresolve depends on dns/adns, what happens if you run the following command? (to test if it not an issue with libadns)
>   $ /usr/local/bin/adnslogres $logfile

I tried this before and adnslogres works without any issue. The problem 
(Bus error / core dump) is only with dns-terror command and only if it 
find some IP address in the log. core dump when trying to resolve this 
IP. If log doesn't contain any valid IP dns-terror doesn't crash.

It is the same on all 10.2 machines. All machines have fastresolv 
package from the same poudriere build.
Machine with 8.4 i386 works fine (fastresolv is also build in poudriere)

I don't know how can I debug it with truss / ktrace / gdb.

Miroslav Lachman



More information about the freebsd-ports mailing list