Gettext Issues

@lbutlr kremels at
Sat Dec 17 00:17:55 UTC 2016

> On 16 Dec 2016, at 00:22, @lbutlr <kremels at> wrote:
>> 2014-11-30
>> Affects: users of devel/gettext (close to everyone)
>> Author: tijl at
>> Reason: 
>>  The devel/gettext port has been split up in devel/gettext-runtime, a
>>  lightweight package containing runtime libraries, and devel/gettext-tools,
>>  a package containing developer tools.  The devel/gettext port still exists
>>  as a metaport.
>>  You must first delete the existing installation of gettext and then
>>  reinstall it.  This will break sudo, so you *must* do this in a root
>>  shell (sudo -i) if you use sudo.
> I cannot imagine that gettext hasn't been updated on my system in over 2 years, but I seem to be having an issue that appears to be related to this based on the errors.
> Shared object "" not found, required by "bash"
> For example.
> I have logged into the console directly as the root user and tried to build gettext via portmaster of via make clean && make install but I get errors about missing files.
> pkg-static: Unable to access file /usr/ports/devel/gettext-runtime/work/stage/usr/local/include/autosprintf.h: No such file or directory
> I've tried to build gettext-runtime first, but to no avail.

To clarify, if I try to make gettext-runtime it ends with:

install  -m 0644 ABOUT-NLS '/usr/ports/devel/gettext-runtime/work/stage/usr/local/share/gettext'
====> Compressing man pages (compress-man)
ls: /usr/ports/devel/gettext-runtime/work/stage/usr/local/info/*: No such file or directory

And the error is correct, the file does not exist.

More information about the freebsd-ports mailing list