Gettext Issues

@lbutlr kremels at
Fri Dec 16 19:49:53 UTC 2016

> 2014-11-30
> Affects: users of devel/gettext (close to everyone)
> Author: tijl at
> Reason: 
>   The devel/gettext port has been split up in devel/gettext-runtime, a
>   lightweight package containing runtime libraries, and devel/gettext-tools,
>   a package containing developer tools.  The devel/gettext port still exists
>   as a metaport.
>   You must first delete the existing installation of gettext and then
>   reinstall it.  This will break sudo, so you *must* do this in a root
>   shell (sudo -i) if you use sudo.

I cannot imagine that gettext hasn't been updated on my system in over 2 years, but I seem to be having an issue that appears to be related to this based on the errors.

Shared object "" not found, required by "bash"

For example.

I have logged into the console directly as the root user and tried to build gettext via portmaster of via make clean && make install but I get errors about missing files.

pkg-static: Unable to access file /usr/ports/devel/gettext-runtime/work/stage/usr/local/include/autosprintf.h: No such file or directory

I've tried to build gettext-runtime first, but to no avail.

More information about the freebsd-ports mailing list