sysutils/php56-fileinfo exit signal Segmentation fault

Miroslav Lachman 000.fbsd at
Fri Dec 16 01:43:16 UTC 2016

I am running webmail Roundcube on many machines but on one machine file 
upload (attachment) doesn't work. I tracked it down to PHP extension 
fileinfo. Everytime I tried to upload a file I got this error in Apache 
error log:

[Fri Dec 16 02:35:27.775113 2016] [core:notice] [pid 6883] AH00052: 
child pid 6890 exit signal Segmentation fault (11)


[Fri Dec 16 02:36:02.110390 2016] [core:notice] [pid 6883] AH00052: 
child pid 6998 exit signal Bus error (10)

If fileinfo extension is disabled (removed ext-20-fileinfo.ini from 
/usr/local/etc/php/) upload works fine.
I tried to change the order of extension but it doesn't change anything 
if it is last or second or anywhere in the middle of the list.

I don't know what can be wrong on this machine because all machines have 
pkgs from the same poudriere repo. All are running Apache 2.4 and PHP 5.6.

Does anybody have some idea how to solve this?

(I cannot disable fileinfo because it is needed by other websites on 
this machine)

Miroslav Lachman

More information about the freebsd-ports mailing list