Samba 4.3 compile fails with CUPS option set

Frank Seltzer frank_s at
Fri Apr 15 14:31:15 UTC 2016

I've been having this problem since the port update a few days ago.  I've 
tried with and without CUPS set multiple times each and 'with' always 
fails in the same place with the same error and 'without' always completes 

The ports/UPDATING file SAMBA entry dated 20160412 only refers to the 
BadLock vulnerability.  Since it showed no example update commands for 
pkg, portupgrade or portmaster I expected a straightforward compile and 

Ports are updated every night at 8:00 PM EDT using svnlite and the 
Makefile appears to be up to date:

# $FreeBSD: head/net/samba43/Makefile 413163 2016-04-12 22:44:03Z timur $

[3342/3873] Linking default/lib/util/
default/source3/client/smbspool_krb5_wrapper_170.o: In function `main':
undefined reference to `clearenv'
cc: error: linker command failed with exit code 1 (use -v to see 
runner cc default/source3/lib/asys/tests_2.o 
default/source3/lib/pthreadpool/pthreadpool_1.o -o 
-fstack-protector -pie -Wl,-z,relro,-z,now -lpthread -Wl,-no-undefined 
-Wl,--export-dynamic -Wl,--as-needed 
-Ldefault/lib/replace -L/usr/local/lib -Wl,-Bdynamic -lreplace-samba4 -lrt 
runner cc default/lib/util/close_low_fd_7.o default/lib/util/debug_8.o -o 
-fstack-protector -Wl,-z,relro,-z,now -lpthread -Wl,-no-undefined 
-Wl,--export-dynamic -Wl,--as-needed -shared 
-Ldefault/lib/replace -Ldefault/lib/util -L/usr/local/lib -Wl,-Bdynamic 
-ltime-basic-samba4 -lsocket-blocking-samba4 -lreplace-samba4 -lrt -lcrypt 
Waf: Leaving directory `/usr/ports/net/samba43/work/samba-4.3.8/bin'
Build failed:  -> task failed (err #1):
         {task: cc_link dynconfig_1.o,smbspool_krb5_wrapper_170.o -> 
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure 
the maintainer.
*** Error code 1

make[1]: stopped in /usr/ports/net/samba43
*** Error code 1

make: stopped in /usr/ports/net/samba43
** Command failed [exit code 1]: /usr/bin/script -qa 
/tmp/portupgrade20160415-11962-1bfjw2n env UPGRADE_TOOL=portupgrade 
UPGRADE_PORT=samba43-4.3.8 UPGRADE_PORT_VER=4.3.8 make
** Fix the problem and try again.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
         ! net/samba43 (samba43-4.3.8)   (interrupted by user)

More information about the freebsd-ports mailing list