impossible to compile firefox when WRKDIRPREFIX is used

Erich Dollansky erichsfreebsdlist at
Sun Apr 10 02:47:05 UTC 2016


On Sat, 09 Apr 2016 21:14:06 +0200
Jan Beich <jbeich at> wrote:

> Erich Dollansky <erichsfreebsdlist at> writes:
> > Hi,
> >
> > I use WRKDIRPREFIX as a standard outside of jails. I could not
> > compile there firefox since some time. I started to investigate
> > today with a ports tree from last Sunday/Monday and still have had
> > this problem.
> >
> > After removing WRKDIRPREFIX, it all worked as expected.  
> Does it look like the following issue?

no, ah, I forgot to a the output.


checking for pixman-1 >= 0.19.2... yes
checking MOZ_PIXMAN_CFLAGS... -I/usr/local/include/pixman-1  
checking MOZ_PIXMAN_LIBS... -L/usr/local/lib -lpixman-1  
checking for stdint.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for posix_fadvise... (cached) yes
checking for posix_fallocate... (cached) yes
checking for icu-i18n >= 50.1... yes
checking MOZ_ICU_CFLAGS... -I/usr/local/include  
checking MOZ_ICU_LIBS... -licui18n -L/usr/local/lib -licuuc -licudata  
creating ./config.status

Reticulating splines...
Traceback (most recent call last):
  File "./config.status", line 1075, in <module>
line 175, in config_status definitions = list(definitions) File
line 165, in emit for out in output: File
line 1062, in read_mozbuild raise bre
============================== ERROR PROCESSING MOZBUILD FILE

The error occurred while processing the following file:


The underlying problem is an illegal file access. This is likely due to
trying to access a file outside of the top source directory.

The path whose access was denied is:


Modify the script to not access this file and try again.

*** Fix above errors and then restart with\
               "gmake -f build"
recipe for target 'configure' failed gmake[4]: *** [configure] Error 1
gmake[4]: Leaving directory
'/usr/home/Depot/PORTS/work/usr/ports/www/firefox/work/firefox-45.0.1' /usr/home/Depot/PORTS/work/usr/ports/www/firefox/work/firefox-45.0.1/
recipe for target
failed gmake[3]: ***
Error 2 gmake[3]: Leaving directory
'/usr/home/Depot/PORTS/work/usr/ports/www/firefox/work/firefox-45.0.1' /usr/home/PORTS/work/usr/ports/www/firefox/work/firefox-45.0.1/
recipe for target 'build' failed gmake[2]: *** [build] Error 2
gmake[2]: Leaving directory
===> Compilation failed unexpectedly. Try to set MAKE_JOBS_UNSAFE=yes
and rebuild before reporting the failure to the maintainer. *** Error
code 1

make[1]: stopped in /usr/ports/www/firefox
*** Error code 1

make: stopped in /usr/ports/www/firefox

I just ran this after removing WRKDIRPREFIX from the environment.
Before I have been able to built firefox without WRKDIRPREFIX in the
same shell. The same error happens in a fresh shell. If it matters, I
believe that 37 was the last version I could built with WRKDIRPREFIX.

I have compiled more than 100 ports these days on the machine. All
others did not have a problem with WRKDIRPREFIX.


More information about the freebsd-ports mailing list