Ports requires pkg 1.6.0, but 1.5.6 is the latest available

Janky Jay, III jankyj at unfs.us
Tue Sep 29 15:30:18 UTC 2015

Hash: SHA1


On 09/29/2015 02:12 AM, Mel Pilgrim wrote:
> On 2015-09-28 21:31, Kevin Oberman wrote:
>> On Mon, Sep 28, 2015 at 4:41 PM, Mel Pilgrim 
>> <list_freebsd at bluerosetech.com> wrote:
>>> I'm trying to build and install security/openssh-portable, but 
>>> when I do, make errors out with:
>>> ===>  openssh-portable-7.1.p1_2,1 pkg(8) must be version 1.6.0 
>>> or greater, but you have 1.5.6. You must upgrade the 
>>> ports-mgmt/pkg port first. *** Error code 1
>>> Stop. make: stopped in /usr/ports/security/openssh-portable
>>> I'm using an svn checkout of 
>>> https://svn.freebsd.org/ports/head.  I also cleaned my package 
>>> cache and forced an update of the local catalogues, but pkg 
>>> tells me the latest version of pkg available, at least for 
>>> amd64 10.2p3, is 1.5.6.
>>> I rolled back my local ports tree to r397904 (r397905 was the 
>>> MINIMAL_PKG_VERSION bump) and it works fine.
>>> I'm guessing from other posts on this list that pkg 1.6.0 out, 
>>> but it doesn't seem to be in the public pkg repo.  I didn't
>>> see anything in UPDATING about it.
>>> What am I missing?
>> I believe that 10.2p3 only updated to the latest quarterly 
>> package build. If you want something more recent, you will need 
>> to edit the config file (/etc/pkg/FreeBSD.conf) to use "latest" 
>> repo. I believe that url: "pkg+ 
>> http://pkg.FreeBSD.org/${ABI}/latest" should do the trick.
>> More of concern is why svn is not working. What does "svn info 
>> /usr/ports" show? "svn status /usr/ports"? I and assure you that 
>> pkg-1.6.1 IS in svn. I have it and built and installed it
>> earlier today. You can confirm what is in the repo by checking
>> out the web interface: 
>> https://svnweb.freebsd.org/ports/head/ports-mgmt/pkg/.
> svn is working fine. pkg is installed from pkgs, not ports.  The 
> issue I'm raising is that the ports tree made mandatory something 
> that isn't available by default in 10.2.
> I ultimately fixed it by switching to the "latest" repo (the repo 
> config edit you mentioned).  I was already disinterested in the 
> quarterly repos because it smacks of Debian-ness, and this
> confirms why stability-by-staleness is a bad idea.

	I ran into this exact same issue using SVN and portmaster to upgrade
'git'. Upgrading 'pkg' using portmaster (portmaster -d 'pkg-1.5.6')
before running 'portmaster -ad' fixed the issue. Generally, though,
portmaster usually updates pkg first and then moves along the rest of
the updates automatically. For whatever reason, that was not the case

Janky Jay, III

Version: GnuPG v2


More information about the freebsd-ports mailing list