Anyone got RethinkDB working in FreeBSD?

Peter list-freebsd-ports at
Fri Sep 11 16:22:35 UTC 2015

On Fri, Sep 11, 2015 at 05:21:18PM +0200, Kurt Jaeger wrote:
> Hi!
> >
> > 
> > I tried compiling it in FreeBSD 9.3, and managed
> > to get past configure and the start of gmake, but
> > then got a lot of these:
> Here's a shar file, which overcomes the BREAKPOINT stuff
> and quite a bit more, but still needs more patching. So
> it's still a work in progress, but feel free to try it.
> -- 
> pi at            +49 171 3101372                         5 years to go !


I tried your file, but didn't get very far unfortunately.

I had to do these two changes to your Makefile to get past
the configure step:

Add CXX=c++48

Comment cd ${WRKSRC} && ${PATCH} < ${FILESDIR}/

And I moved out of the files directory.

The addition of CXX is because otherwise configure finds
gcc in base, which is too old to be accepted.

The removal of is because that patch
failed, probably because I don't have LDFLAGS anywhere in
my generated I tried adding LDFLAGS, CXXFLAGS
and CFLAGS manually to, but that didn't help.

I get this error after a couple of successful compile lines:

test -e ./build/external/v8_3.30.33.16/include && touch ./build/external/v8_3.30.33.16/include || true
mkdir -p build/release_system/obj/rdb_protocol/ ./build/release_system/dep/rdb_protocol/
c++48 -O2 -pipe -fstack-protector -fno-strict-aliasing -isystem ./build/external/re2_20140111/include -isystem ./build/external/v8_3.30.33.16/include -I./src -pthread "-DPRODUCT_NAME=\"RethinkDB\"" "-D__STDC_LIMIT_MACROS" "-D__STDC_FORMAT_MACROS" -Wall -Wextra "-DRAPIDJSON_HAS_STDSTRING" "-DRAPIDJSON_PARSE_DEFAULT_FLAGS=kParseFullPrecisionFlag" -Wnon-virtual-dtor -Wno-deprecated-declarations -std=gnu++0x -Wformat=2 -Wswitch-enum -Wno-array-bounds -O3 -DNDEBUG -fno-strict-aliasing -g -DHAS_TERMCAP -I./build/release_system/proto -DRETHINKDB_VERSION=\"2.1.3\" -DRETHINKDB_CODE_VERSION=\"2.1.3\" -isystem ./build/external/gtest_1.6.0/include -c -o build/release_system/obj/rdb_protocol/erase_range.o src/rdb_protocol/ \
          -MP -MQ build/release_system/obj/rdb_protocol/erase_range.o -MD -MF ./build/release_system/dep/rdb_protocol/erase_range.d
In file included from ./src/utils.hpp:11:0,
                 from ./src/containers/scoped.hpp:10,
                 from ./src/containers/counted.hpp:10,
                 from ./src/serializer/types.hpp:11,
                 from ./src/buffer_cache/types.hpp:9,
                 from ./src/rdb_protocol/erase_range.hpp:10,
                 from src/rdb_protocol/
/src/debug.hpp: In function 'typename std::enable_if<std::is_arithmetic<_Tp>::value>::type debug_print(printf_buffer_t*, T)':
./src/debug.hpp:32:22: error: 'to_string' is not a member of 'std'
     debug_print(buf, std::to_string(x));


More information about the freebsd-ports mailing list