editors/abiword fails on not-really-missing dependency

Thomas Mueller mueller6724 at bellsouth.net
Mon Mar 30 02:05:40 UTC 2015

I tried to build editors/abiword, but it failed for lack of libwpg-0.1 and libwpd-0.8.

pkg info -a | grep -n "libwp" produces

314:libwpd-0.9.9_2                 Tools for importing and exporting WordPerfect(tm) documents
315:libwpg-0.2.2_3                 Library and tools to work with WordPerfect Graphics (WPG) files

So it looks like I have the required dependencies, but the configure script seemed to be looking for an earlier version.

Relevant part of build log is

configure: error: Package requirements ( libgsf-1 >= 1.12 libwpg-0.1 >= 0.1.0 libwpd-0.8 >= 0.8.0 ) were not met:

Package libwpg-0.1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libwpg-0.1.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libwpg-0.1', required by 'world', not found
Package 'libwpd-0.8', required by 'world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables WPG_CFLAGS
and WPG_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
===>  Script "configure" failed unexpectedly.

Is this a bug in the configure script or FreeBSD ports' patches?

I could cd /usr/local/libdata/pkgconfig  and
ln -s libwpg-0.2.pc libwpg-0.1.pc 
ln -s libwpd-0.9.pc libwpd-0.8.pc

and thereby give the configure script what it's looking for, a kludge with no certainty of success.

Maybe delete the symbolic links afterward.


More information about the freebsd-ports mailing list