cups, and hplip too, fail to recognize printer when I try to print

Thomas Mueller mueller6724 at
Tue Jun 2 10:16:39 UTC 2015

Thomas Mueller wrote:
> I have printer, HP_LaserJet_Professional_M1212nf_MFP, seem to have set
> it up with cups [...]
> lpr: lp: unknown printer

Patrick Hess responded:

> Be aware that after installing CUPS you will find two incompatible lpr
> binaries on your system: /usr/bin/lpr, which belongs to the base system,
> and /usr/local/bin/lpr, the one that comes with CUPS. Unless you changed
> your $PATH to include /usr/local/bin before /usr/bin, you are still
> calling /usr/bin/lpr (use "which lpr" to confirm this). The same goes
> for /usr/bin/lp vs. /usr/local/bin/lp.

> So just try using the full path for /usr/local/bin/lpr and see if that
> does the trick.

> Patrick

I tried that, got some more sign of life, but still no joy:

But it still seems that /usr/local/sbin and /usr/local/bin in FreeBSD, or /usr/pkg/sbin and /usr/pkg/bin in NetBSD, should properly be at the front of the path, unless one wants to put $HOME/bin or the like in front of that.

I get Idle: Filter failed 
on http://localhost:631  status page.

It looks like cups and the printer are finding every silly excuse for refusing to work.

I can't really say if Linux would work better.

Only other way is seeing if the Windows way works in wine.


More information about the freebsd-ports mailing list