updating alpine port to new version (as a maintainer)

Scot Hetzel swhetzel at gmail.com
Sat Jan 17 21:43:41 UTC 2015


On Sat, Jan 17, 2015 at 2:54 PM, Marco Beishuizen <mbeis at xs4all.nl> wrote:
> On Sat, 17 Jan 2015, the wise Scot Hetzel wrote:
>
>> On line 41 of the current ports Makefile, it shows tech-notes.txt:
>>
>> 41 PORTDOCSdoc= brochure.txt tech-notes.txt
>>
>> Then on lines 163-164 in the post-install stage it tries to install them:
>>
>> 163 .for f in ${PORTDOCSdoc}
>> 164   ${INSTALL_MAN} ${WRKSRC}/doc/$f ${STAGEDIR}${DOCSDIR}
>> 165 .endfor
>>
>> Change the PORTDOCSdoc variable to:
>>
>> PORTDOCSdoc= brochure.txt tech-notes/tech-notes.txt
>>
>> This should install the tech-notes.txt file into the ${DOCSDIR}.
>>
>> The other option is to remove tech-notes.txt from PORTDOCSdoc and
>> added it to PORTDOCShtml.  Then update the pkg-plist for the new
>> location.
>
>
> Thank you too Scot for your help. After adjusting these lines (and also one
> in line 145) this part seems to work.
>
> Now it gives a compile error and a lot of warnings during compiling.
>
> The 2 errors are:
>
> maildir.c:1720:66: error: too few arguments to function call, expected 2,
> have 1
>   if (maildir_canonicalize (test, ref, pat) && (s = sm_read (&sdb))) {
>                                                     ~~~~~~~      ^
> maildir.c:1722:30: error: too few arguments to function call, expected 2,
> have 1
>     while ((s = sm_read (&sdb)) != NULL); /* until no more subscriptions */
>
>
Are you using the correct version of the maildir.patch.gz.

If you look on line 116 of the original Makefile, it shows:

116 PATCH_SITES= http://patches.freeiz.com/alpine/patches/alpine-2.11/
117 PATCHFILES+= maildir.patch.gz

You should change that line so that it shows alpine-2.20 or
alpine-${PORTVERSION} instead.

I checked the alpine-2.20/maildir.patch.gz and it shows that sm_read
requires 2 arguments.

Since the patch file isn't versioned, you will have to remove the file
from your distfiles and run make checksum to update the checksum for
the file.

Another option is to change lines 116 and 117 to:

116 PATCH_SITES= http://patches.freeiz.com/alpine/patches/
117 PATCHFILES+= alpine-${PORTVERSION}/maildir.patch.gz

This will ensure everyone has the correct version of the maildir.patch.gz file.

-- 
DISCLAIMER:

No electrons were maimed while sending this message. Only slightly bruised.


More information about the freebsd-ports mailing list